# CVE-2026-73427: Trix: XSS via JSON deserialization bypass in drag-and-drop (Level0InputController)

> Attackers can inject JavaScript via crafted JSON drag-and-drop payloads in Trix editor, requiring user interaction to execute code.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-53p3-c7vp-4mcc

## What is CVE-2026-73427?

CVE-2026-73427 is a low-severity cross-site scripting vulnerability in basecamp trix, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Prior to 2.1.18, Trix is vulnerable to cross-site scripting when a crafted application/x-trix-document JSON payload is dropped into an editor using the fallback Level0InputController, such as an embedded WebView without Input Events Level 2 support. The StringPiece.fromJSON method trusts href attributes from the JSON payload without sanitization, allowing a draggable element containing a javascript: URI to bypass DOMPurify sanitization and inject executable JavaScript into the DOM. Exploitation requires the victim to drag and drop attacker-controlled content, and server-side HTML sanitization can neutralize the payload on save. This issue is fixed in version 2.1.18.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-73427?

4 open source packages ship an affected version, including action_text-trix and trix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `action_text-trix` | RubyGems | All versions | 2.1.18 |
| `action_text-trix` | RubyGems | All versions | 2.1.18 |
| `trix` | npm | All versions | 2.1.18 |
| `trix` | npm | All versions | 2.1.18 |

## How do I fix CVE-2026-73427?

Upgrade action_text-trix to 2.1.18 or later.

## Is CVE-2026-73427 being exploited?

There is no known exploitation of CVE-2026-73427 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73427 and fix it if it is affected.

What it is: CVE-2026-73427 is a low-severity cross-site scripting vulnerability in basecamp trix, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-73427 in the wild and no public exploit code.

Affected packages and fixed versions:
- action_text-trix (RubyGems): affected all versions; fixed in 2.1.18
- action_text-trix (RubyGems): affected all versions; fixed in 2.1.18
- trix (npm): affected all versions; fixed in 2.1.18
- trix (npm): affected all versions; fixed in 2.1.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73427/ (Markdown: https://insights.sbomify.com/CVE-2026-73427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73427
- OSV: https://osv.dev/vulnerability/CVE-2026-73427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73427/
Summaries are generated and may contain mistakes; the official description above is the record.
