# CVE-2026-73429: Russh: client wrong-length X25519 `clone_from_slice` panic (pre-auth DoS)

> A malicious SSH server can crash a russh client session by sending a malformed key exchange reply, causing a panic before host key verification.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73429, GHSA-g9hv-x236-4qp3, UBUNTU-CVE-2026-73429

## What is CVE-2026-73429?

CVE-2026-73429 is a medium-severity denial of service vulnerability in Eugeny russh, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. Prior to 0.62.4, a malicious SSH server can crash a russh client session with a malformed KEX_ECDH_REPLY containing a server ephemeral value that is not 32 bytes long. The client-side Curve25519Kex::compute_shared_secret function in russh/src/kex/curve25519.rs passes the decoded exchange.server_ephemeral value to clone_from_slice without validating its length, causing a deterministic panic before the server host key is verified. The panic terminates the spawned client session task and surfaces as a JoinError, while the embedding process normally remains running. This issue is fixed in version 0.62.4.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2026-73429?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.62.4 |
| `russh` | crates.io | All versions | 0.62.4 |

## How do I fix CVE-2026-73429?

Upgrade russh to 0.62.4 or later.

## Is CVE-2026-73429 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73429 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73429 and fix it if it is affected.

What it is: CVE-2026-73429 is a medium-severity denial of service vulnerability in Eugeny russh, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73429 exists.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.62.4
- russh (crates.io): affected all versions; fixed in 0.62.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73429/ (Markdown: https://insights.sbomify.com/CVE-2026-73429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73429
- OSV: https://osv.dev/vulnerability/CVE-2026-73429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73429/
Summaries are generated and may contain mistakes; the official description above is the record.
