{"answers":{"affected":"2 open source packages ship an affected version, including russh.","exploited":"There is no known exploitation of CVE-2026-73430 in the wild and no public exploit code.","fix":"Upgrade russh to 0.62.4 or later.","what":"CVE-2026-73430 is a medium-severity denial of service vulnerability in Eugeny russh, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73430 and fix it if it is affected.\n\nWhat it is: CVE-2026-73430 is a medium-severity denial of service vulnerability in Eugeny russh, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73430 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected all versions; fixed in 0.62.4\n- russh (crates.io): affected all versions; fixed in 0.62.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73430/ (Markdown: https://insights.sbomify.com/CVE-2026-73430/index.md)","id":"CVE-2026-73430","markdown":"https://insights.sbomify.com/CVE-2026-73430/index.md","name":"CVE-2026-73430","record":{"aliases":["DEBIAN-CVE-2026-73430","GHSA-5xvq-cp9x-6p6r","UBUNTU-CVE-2026-73430"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust SSH library","requires_auth":"none","summary":"An unauthenticated attacker can cause a denial of service in the Russh SSH library by sending a malformed key exchange packet, crashing the server.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"Russh is a Rust SSH client \u0026 server library. Prior to 0.62.4, an unauthenticated SSH client can cause a denial of service by sending SSH_MSG_KEX_ECDH_INIT with a 32-byte all-zero Q_C value. Curve25519Kex::server_dh in russh/src/kex/curve25519.rs accepts the all-zero peer public value and computes an all-zero shared secret, after which compute_exchange_hash calls encode_mpint in russh/src/kex/mod.rs and indexes beyond the end of the input while skipping leading zero bytes. The resulting panic occurs before authentication and terminates the server key-exchange task. This issue is fixed in version 0.62.4.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Russh: Pre-auth remote panic via all-zero Curve25519 peer public value (encode_mpint OOB)","id":"CVE-2026-73430","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Reusable Account Activation and Recovery Tokens Allow Repeated Account Takeover in vulnerability-lookup","id":"CVE-2026-73431"},"packages":[{"ecosystem":"crates.io","fixed":["0.62.4"],"introduced":["0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-5xvq-cp9x-6p6r"},{"ecosystem":"crates.io","fixed":["0.62.4"],"introduced":["0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-5xvq-cp9x-6p6r"}],"prev":{"headline":"Russh: client wrong-length X25519 `clone_from_slice` panic (pre-auth DoS)","id":"CVE-2026-73429"},"products":["russh"],"published":"2026-08-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-13","vendors":["Eugeny"]},"summary":"An unauthenticated attacker can cause a denial of service in the Russh SSH library by sending a malformed key exchange packet, crashing the server.","url":"https://insights.sbomify.com/CVE-2026-73430/"}