# CVE-2026-73430: Russh: Pre-auth remote panic via all-zero Curve25519 peer public value (encode_mpint OOB)

> An unauthenticated attacker can cause a denial of service in the Russh SSH library by sending a malformed key exchange packet, crashing the server.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73430, GHSA-5xvq-cp9x-6p6r, UBUNTU-CVE-2026-73430

## What is CVE-2026-73430?

CVE-2026-73430 is a medium-severity denial of service vulnerability in Eugeny russh, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. Prior to 0.62.4, an unauthenticated SSH client can cause a denial of service by sending SSH_MSG_KEX_ECDH_INIT with a 32-byte all-zero Q_C value. Curve25519Kex::server_dh in russh/src/kex/curve25519.rs accepts the all-zero peer public value and computes an all-zero shared secret, after which compute_exchange_hash calls encode_mpint in russh/src/kex/mod.rs and indexes beyond the end of the input while skipping leading zero bytes. The resulting panic occurs before authentication and terminates the server key-exchange task. This issue is fixed in version 0.62.4.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-73430?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.62.4 |
| `russh` | crates.io | All versions | 0.62.4 |

## How do I fix CVE-2026-73430?

Upgrade russh to 0.62.4 or later.

## Is CVE-2026-73430 being exploited?

There is no known exploitation of CVE-2026-73430 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73430 and fix it if it is affected.

What it is: CVE-2026-73430 is a medium-severity denial of service vulnerability in Eugeny russh, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73430 in the wild and no public exploit code.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.62.4
- russh (crates.io): affected all versions; fixed in 0.62.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73430/ (Markdown: https://insights.sbomify.com/CVE-2026-73430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73430
- OSV: https://osv.dev/vulnerability/CVE-2026-73430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73430/
Summaries are generated and may contain mistakes; the official description above is the record.
