CVE-2026-73483 Flowise before 3.1.3 Sandbox Escape via Puppeteer
Authenticated attackers can escape the JavaScript sandbox to execute arbitrary OS commands and read host files via Puppeteer configuration.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73483?
CVE-2026-73483 is a critical command injection vulnerability in Flowiseai Flowise, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Flowise (packages flowise and flowise-components) in versions <= 3.1.2 contain a sandbox escape in the vm2/@flowiseai/nodevm JavaScript sandbox. An authenticated user with access to the /api/v1/node-custom-function endpoint can escape the sandbox by supplying attacker-controlled executablePath and args parameters to puppeteer.launch(), which internally invokes child_process.spawn() outside the sandbox boundary. This allows execution of arbitrary OS commands as the Flowise process user (root in the official Docker image) and arbitrary host file disclosure via Chromium's file:// URL handling. In versions 3.0.8–3.1.2 exploitation requires ALLOW_BUILTIN_DEP=true; earlier versions are exploitable by default. Fixed in 3.1.3.
Weakness: CWE-78
Which versions are affected by CVE-2026-73483?
4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flowise npm | All versions | 3.1.3 |
flowise npm | All versions | 3.1.3 |
flowise-components npm | All versions | 3.1.3 |
flowise-components npm | All versions | 3.1.3 |
Products include Flowiseai Flowise.
How do I fix CVE-2026-73483?
Upgrade flowise to 3.1.3 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-73483 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73483 exists.
Other vulnerabilities in Flowiseai Flowise
- CVE-2025-71338 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API
- CVE-2026-40933 Flowise: Authenticated RCE Via MCP Adapters
- CVE-2025-61913 Flowise is vulnerable to arbitrary file read, arbitrary file write
- CVE-2025-59528 Flowise has Remote Code Execution vulnerability
- CVE-2026-52098 Code injection in n/a
Sources
Also known as GHSA-9gvv-qjj3-2p6g.