# CVE-2026-73487: Flowise before 3.1.3 Prompt Injection RCE via CSV Agent

> Unauthenticated attackers can achieve remote code execution and data exfiltration in Flowise by bypassing Python code validators via prompt injection in CSV and Airtable agents.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-w7x8-q2gp-5cgg

## What is CVE-2026-73487?

CVE-2026-73487 is a critical code injection vulnerability in Flowiseai Flowise, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flowise before 3.1.3 contains a regex-based Python code validator bypass in CSV and Airtable Agent nodes that allows unauthenticated attackers to inject malicious code via prompt injection. Attackers can exploit unblocked pandas functions like pd.read_json() to exfiltrate datasets, perform SSRF against internal services, or achieve code execution through the unauthenticated prediction API.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-73487?

4 open source packages ship an affected version, including flowise and flowise-components. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise-components` | npm | All versions | 3.1.3 |
| `flowise-components` | npm | All versions | 3.1.3 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-73487?

Upgrade flowise to 3.1.3 or later.

## Is CVE-2026-73487 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73487 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73487 and fix it if it is affected.

What it is: CVE-2026-73487 is a critical code injection vulnerability in Flowiseai Flowise, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73487 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise-components (npm): affected all versions; fixed in 3.1.3
- flowise-components (npm): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73487/ (Markdown: https://insights.sbomify.com/CVE-2026-73487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73487
- OSV: https://osv.dev/vulnerability/CVE-2026-73487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73487/
Summaries are generated and may contain mistakes; the official description above is the record.
