# CVE-2026-73488: Flowise before 3.1.3 IDOR via customer-default-source endpoint

> Authenticated attackers can access other customers' sensitive payment and profile data by manipulating the customerId parameter in the customer-default-source endpoint.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-2364-jh4q-m9vm, GHSA-p4mj-q6c6-6f68

## What is CVE-2026-73488?

CVE-2026-73488 is a medium-severity missing authorization vulnerability in Flowiseai Flowise, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Flowise versions before 3.1.3 contain an insecure direct object reference vulnerability in the GET /api/v1/organization/customer-default-source endpoint that allows authenticated attackers to access other customers' payment and profile data by manipulating the customerId parameter. Attackers can enumerate predictable customer IDs to retrieve sensitive information including email addresses, account balances, currency types, and billing configurations without authorization checks.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-73488?

2 open source packages ship an affected version, including flowise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flowise` | npm | All versions | 3.1.3 |
| `flowise` | npm | All versions | 3.1.3 |

Products: Flowiseai Flowise.

## How do I fix CVE-2026-73488?

Upgrade flowise to 3.1.3 or later.

## Is CVE-2026-73488 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73488 exists.

## Other vulnerabilities in Flowiseai Flowise

- [CVE-2025-71338](https://insights.sbomify.com/CVE-2025-71338/): Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API (critical 10.0)
- [CVE-2026-40933](https://insights.sbomify.com/CVE-2026-40933/): Flowise: Authenticated RCE Via MCP Adapters (critical 10.0)
- [CVE-2025-61913](https://insights.sbomify.com/CVE-2025-61913/): Flowise is vulnerable to arbitrary file read, arbitrary file write (critical 10.0)
- [CVE-2025-59528](https://insights.sbomify.com/CVE-2025-59528/): Flowise has Remote Code Execution vulnerability (critical 10.0)
- [CVE-2026-52098](https://insights.sbomify.com/CVE-2026-52098/): Code injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73488 and fix it if it is affected.

What it is: CVE-2026-73488 is a medium-severity missing authorization vulnerability in Flowiseai Flowise, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73488 exists.

Affected packages and fixed versions:
- flowise (npm): affected all versions; fixed in 3.1.3
- flowise (npm): affected all versions; fixed in 3.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73488/ (Markdown: https://insights.sbomify.com/CVE-2026-73488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73488
- OSV: https://osv.dev/vulnerability/CVE-2026-73488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73488/
Summaries are generated and may contain mistakes; the official description above is the record.
