{"answers":{"affected":"2 open source packages ship an affected version, including russh.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73489 exists.","fix":"Upgrade russh to 0.62.4 or later.","what":"CVE-2026-73489 is a medium-severity denial of service vulnerability in Eugeny russh, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73489 and fix it if it is affected.\n\nWhat it is: CVE-2026-73489 is a medium-severity denial of service vulnerability in Eugeny russh, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73489 exists.\n\nAffected packages and fixed versions:\n- russh (crates.io): affected all versions; fixed in 0.62.4\n- russh (crates.io): affected all versions; fixed in 0.62.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73489/ (Markdown: https://insights.sbomify.com/CVE-2026-73489/index.md)","id":"CVE-2026-73489","markdown":"https://insights.sbomify.com/CVE-2026-73489/index.md","name":"CVE-2026-73489","record":{"aliases":["DEBIAN-CVE-2026-73489","GHSA-cqjc-rmpq-xprq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust SSH library","requires_auth":"low_privilege","summary":"An authenticated attacker can crash the SSH server by sending a pty-req with excessive terminal-mode records, causing a panic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-129","name":"Improper Validation of Array Index"}],"description":"Russh is a Rust SSH client \u0026 server library. Prior to 0.62.4, an authenticated SSH client can cause a denial of service by sending a pty-req channel request with more than 130 terminal-mode records. The parser in russh/src/server/encrypted.rs stores terminal modes in a fixed 130-entry [(Pty::TTY_OP_END, 0); 130] array but continues increasing the mode count, then constructs an out-of-bounds slice and panics before the application pty_request handler runs. The panic terminates the server session task without causing memory corruption. This issue is fixed in version 0.62.4.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records","id":"CVE-2026-73489","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Loofah: SVG `href` attribute bypasses local-reference restriction","id":"CVE-2026-73490"},"packages":[{"ecosystem":"crates.io","fixed":["0.62.4"],"introduced":["0"],"last_affected":[],"package":"russh","purl":null,"source":"GHSA-cqjc-rmpq-xprq"},{"ecosystem":"crates.io","fixed":["0.62.4"],"introduced":["0"],"last_affected":[],"package":"russh","purl":"pkg:cargo/russh","source":"GHSA-cqjc-rmpq-xprq"}],"prev":{"headline":"Flowise before 3.1.3 IDOR via customer-default-source endpoint","id":"CVE-2026-73488"},"products":["russh"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-17","vendors":["Eugeny"]},"summary":"An authenticated attacker can crash the SSH server by sending a pty-req with excessive terminal-mode records, causing a panic.","url":"https://insights.sbomify.com/CVE-2026-73489/"}