# CVE-2026-73489: Russh: Post-auth remote panic via pty-req with more than 130 terminal-mode records

> An authenticated attacker can crash the SSH server by sending a pty-req with excessive terminal-mode records, causing a panic.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73489, GHSA-cqjc-rmpq-xprq

## What is CVE-2026-73489?

CVE-2026-73489 is a medium-severity denial of service vulnerability in Eugeny russh, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Russh is a Rust SSH client & server library. Prior to 0.62.4, an authenticated SSH client can cause a denial of service by sending a pty-req channel request with more than 130 terminal-mode records. The parser in russh/src/server/encrypted.rs stores terminal modes in a fixed 130-entry [(Pty::TTY_OP_END, 0); 130] array but continues increasing the mode count, then constructs an out-of-bounds slice and panics before the application pty_request handler runs. The panic terminates the server session task without causing memory corruption. This issue is fixed in version 0.62.4.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-73489?

2 open source packages ship an affected version, including russh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `russh` | crates.io | All versions | 0.62.4 |
| `russh` | crates.io | All versions | 0.62.4 |

## How do I fix CVE-2026-73489?

Upgrade russh to 0.62.4 or later.

## Is CVE-2026-73489 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73489 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73489 and fix it if it is affected.

What it is: CVE-2026-73489 is a medium-severity denial of service vulnerability in Eugeny russh, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73489 exists.

Affected packages and fixed versions:
- russh (crates.io): affected all versions; fixed in 0.62.4
- russh (crates.io): affected all versions; fixed in 0.62.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73489/ (Markdown: https://insights.sbomify.com/CVE-2026-73489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73489
- OSV: https://osv.dev/vulnerability/CVE-2026-73489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73489/
Summaries are generated and may contain mistakes; the official description above is the record.
