CVE-2026-73493 http4s-blaze-server: Unbounded WebSocket message aggregation
Attackers can cause server crashes via unbounded WebSocket message aggregation in http4s-blaze-server, requiring an upgrade to fix.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73493?
CVE-2026-73493 is a high-severity denial of service vulnerability in http4s blaze, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Http4s (http4s-blaze-server) is a minimal, idiomatic Scala interface for HTTP services. Prior to 0.23.18 and 1.0.0-M42, http4s-blaze-server aggregates fragments of an incoming WebSocket message with no limit on total size or fragment count. A client that completes a WebSocket handshake can send an unterminated fragmented message and drive unbounded heap growth in the server JVM, resulting in denial of service through OutOfMemoryError. Any http4s application serving WebSocket routes over BlazeServerBuilder is affected, no non-default configuration is required, and maxWebSocketBufferSize does not bound the aggregate because it bounds only individual frames. A single connection sending continuation frames that never set FIN forces the server to buffer every fragment until the heap is exhausted, terminating the JVM with OutOfMemoryError on the blaze selector thread. Small fragments amplify the cost through per-frame object overhead, so a modest volume of wire bytes is sufficient. This issue is fixed in versions 0.23.18 and 1.0.0-M42.
Weakness: CWE-770
Which versions are affected by CVE-2026-73493?
8 open source packages ship an affected version, including org.http4s:http4s-blaze-server_2.13, org.http4s:http4s-blaze-server_2.12 and org.http4s:http4s-blaze-server_3.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:http4s-blaze-server_2.13 Maven | All versions | 0.23.18 |
org.http4s:http4s-blaze-server_2.13 Maven | All versions | 0.23.18 |
org.http4s:http4s-blaze-server_2.13 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:http4s-blaze-server_2.13 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:http4s-blaze-server_2.12 Maven | All versions | 0.23.18 |
org.http4s:http4s-blaze-server_2.12 Maven | All versions | 0.23.18 |
2 more packages
org.http4s:http4s-blaze-server_3 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:http4s-blaze-server_3 Maven | From 1.0.0-M1 | 1.0.0-M42 |
How do I fix CVE-2026-73493?
Upgrade org.http4s:http4s-blaze-server_2.13 to a fixed version for your release line: 0.23.18 or 1.0.0-M42.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-73493 being exploited?
There is no known exploitation of CVE-2026-73493 in the wild and no public exploit code.
Sources
Also known as GHSA-7ppr-r889-mcf2.