# CVE-2026-73493: http4s-blaze-server: Unbounded WebSocket message aggregation

> Attackers can cause server crashes via unbounded WebSocket message aggregation in http4s-blaze-server, requiring an upgrade to fix.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-7ppr-r889-mcf2

## What is CVE-2026-73493?

CVE-2026-73493 is a high-severity denial of service vulnerability in http4s blaze, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Http4s (http4s-blaze-server) is a minimal, idiomatic Scala interface for HTTP services. Prior to 0.23.18 and 1.0.0-M42, http4s-blaze-server aggregates fragments of an incoming WebSocket message with no limit on total size or fragment count. A client that completes a WebSocket handshake can send an unterminated fragmented message and drive unbounded heap growth in the server JVM, resulting in denial of service through OutOfMemoryError. Any http4s application serving WebSocket routes over BlazeServerBuilder is affected, no non-default configuration is required, and maxWebSocketBufferSize does not bound the aggregate because it bounds only individual frames. A single connection sending continuation frames that never set FIN forces the server to buffer every fragment until the heap is exhausted, terminating the JVM with OutOfMemoryError on the blaze selector thread. Small fragments amplify the cost through per-frame object overhead, so a modest volume of wire bytes is sufficient. This issue is fixed in versions 0.23.18 and 1.0.0-M42.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-73493?

8 open source packages ship an affected version, including org.http4s:http4s-blaze-server_2.13, org.http4s:http4s-blaze-server_2.12 and org.http4s:http4s-blaze-server_3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:http4s-blaze-server_2.13` | Maven | All versions | 0.23.18 |
| `org.http4s:http4s-blaze-server_2.13` | Maven | All versions | 0.23.18 |
| `org.http4s:http4s-blaze-server_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:http4s-blaze-server_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:http4s-blaze-server_2.12` | Maven | All versions | 0.23.18 |
| `org.http4s:http4s-blaze-server_2.12` | Maven | All versions | 0.23.18 |
| `org.http4s:http4s-blaze-server_3` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:http4s-blaze-server_3` | Maven | From 1.0.0-M1 | 1.0.0-M42 |

## How do I fix CVE-2026-73493?

Upgrade org.http4s:http4s-blaze-server_2.13 to a fixed version for your release line: 0.23.18 or 1.0.0-M42.

## Is CVE-2026-73493 being exploited?

There is no known exploitation of CVE-2026-73493 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73493 and fix it if it is affected.

What it is: CVE-2026-73493 is a high-severity denial of service vulnerability in http4s blaze, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73493 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:http4s-blaze-server_2.13 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:http4s-blaze-server_2.13 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:http4s-blaze-server_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:http4s-blaze-server_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:http4s-blaze-server_2.12 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:http4s-blaze-server_2.12 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:http4s-blaze-server_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:http4s-blaze-server_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73493/ (Markdown: https://insights.sbomify.com/CVE-2026-73493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73493
- OSV: https://osv.dev/vulnerability/CVE-2026-73493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73493/
Summaries are generated and may contain mistakes; the official description above is the record.
