CVE-2026-73494 blaze: Multiple HTTP/1.1 request-smuggling primitives in blaze's Java wire parser
Attackers can exploit HTTP request smuggling in blaze to bypass authorization or poison caches when paired with a lenient proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73494?
CVE-2026-73494 is a high-severity vulnerability in http4s blaze, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
blaze is a Scala library for building asynchronous pipelines, with a focus on network IO. Prior to 0.23.18 and from 1.0.0-M1 until 1.0.0-M42, five HTTP/1.1 conformance laxities in the hand-written Java parser under http/src/main/java/org/http4s/blaze/http/parser/ can cause blaze to derive a different request boundary than a stricter fronting intermediary. A default BlazeServerBuilder accepts invalid or valueless header field names that violate tchar syntax, obsolete folded field lines (obs-fold), unsupported Transfer-Encoding values, duplicate Content-Length fields, and requests containing both Transfer-Encoding and Content-Length. If a lenient or legacy proxy forwards the malformed bytes but interprets them differently, the disagreement can permit front-end authorization bypass, response-queue poisoning on pooled backend connections, or cache poisoning. Exploitation requires a pair of disagreeing parsers; no non-default blaze configuration is required. The affected checks are enforced in BodyAndHeaderParser and Http1ServerParser. This issue is fixed in versions 0.23.18 and 1.0.0-M42.
Weakness: CWE-444
Which versions are affected by CVE-2026-73494?
10 open source packages ship an affected version, including org.http4s:blaze-http_2.13, org.http4s:blaze-http_3 and org.http4s:http4s-blaze-server_2.13.
| Package | Affected | Fixed in |
|---|---|---|
org.http4s:blaze-http_2.13 Maven | All versions | 0.23.18 |
org.http4s:blaze-http_2.13 Maven | All versions | 0.23.18 |
org.http4s:blaze-http_2.13 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:blaze-http_2.13 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:blaze-http_3 Maven | All versions | 0.23.18 |
org.http4s:blaze-http_3 Maven | All versions | 0.23.18 |
4 more packages
org.http4s:blaze-http_3 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:blaze-http_3 Maven | From 1.0.0-M1 | 1.0.0-M42 |
org.http4s:http4s-blaze-server_2.13 Maven | All versions | 0.23.18 |
org.http4s:http4s-blaze-server_2.13 Maven | All versions | 0.23.18 |
How do I fix CVE-2026-73494?
Upgrade org.http4s:blaze-http_2.13 to a fixed version for your release line: 0.23.18 or 1.0.0-M42.
Is CVE-2026-73494 being exploited?
There is no known exploitation of CVE-2026-73494 in the wild and no public exploit code.
Sources
Also known as GHSA-mhvj-jhpq-885v.