# CVE-2026-73494: blaze: Multiple HTTP/1.1 request-smuggling primitives in blaze's Java wire parser

> Attackers can exploit HTTP request smuggling in blaze to bypass authorization or poison caches when paired with a lenient proxy.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-mhvj-jhpq-885v

## What is CVE-2026-73494?

CVE-2026-73494 is a high-severity vulnerability in http4s blaze, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

blaze is a Scala library for building asynchronous pipelines, with a focus on network IO. Prior to 0.23.18 and from 1.0.0-M1 until 1.0.0-M42, five HTTP/1.1 conformance laxities in the hand-written Java parser under http/src/main/java/org/http4s/blaze/http/parser/ can cause blaze to derive a different request boundary than a stricter fronting intermediary. A default BlazeServerBuilder accepts invalid or valueless header field names that violate tchar syntax, obsolete folded field lines (obs-fold), unsupported Transfer-Encoding values, duplicate Content-Length fields, and requests containing both Transfer-Encoding and Content-Length. If a lenient or legacy proxy forwards the malformed bytes but interprets them differently, the disagreement can permit front-end authorization bypass, response-queue poisoning on pooled backend connections, or cache poisoning. Exploitation requires a pair of disagreeing parsers; no non-default blaze configuration is required. The affected checks are enforced in BodyAndHeaderParser and Http1ServerParser. This issue is fixed in versions 0.23.18 and 1.0.0-M42.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-73494?

10 open source packages ship an affected version, including org.http4s:blaze-http_2.13, org.http4s:blaze-http_3 and org.http4s:http4s-blaze-server_2.13.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4s:blaze-http_2.13` | Maven | All versions | 0.23.18 |
| `org.http4s:blaze-http_2.13` | Maven | All versions | 0.23.18 |
| `org.http4s:blaze-http_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:blaze-http_2.13` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:blaze-http_3` | Maven | All versions | 0.23.18 |
| `org.http4s:blaze-http_3` | Maven | All versions | 0.23.18 |
| `org.http4s:blaze-http_3` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:blaze-http_3` | Maven | From 1.0.0-M1 | 1.0.0-M42 |
| `org.http4s:http4s-blaze-server_2.13` | Maven | All versions | 0.23.18 |
| `org.http4s:http4s-blaze-server_2.13` | Maven | All versions | 0.23.18 |

## How do I fix CVE-2026-73494?

Upgrade org.http4s:blaze-http_2.13 to a fixed version for your release line: 0.23.18 or 1.0.0-M42.

## Is CVE-2026-73494 being exploited?

There is no known exploitation of CVE-2026-73494 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73494 and fix it if it is affected.

What it is: CVE-2026-73494 is a high-severity vulnerability in http4s blaze, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73494 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4s:blaze-http_2.13 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:blaze-http_2.13 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:blaze-http_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:blaze-http_2.13 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:blaze-http_3 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:blaze-http_3 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:blaze-http_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:blaze-http_3 (Maven): affected from 1.0.0-M1; fixed in 1.0.0-M42
- org.http4s:http4s-blaze-server_2.13 (Maven): affected all versions; fixed in 0.23.18
- org.http4s:http4s-blaze-server_2.13 (Maven): affected all versions; fixed in 0.23.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73494/ (Markdown: https://insights.sbomify.com/CVE-2026-73494/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73494
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73494
- OSV: https://osv.dev/vulnerability/CVE-2026-73494

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73494/
Summaries are generated and may contain mistakes; the official description above is the record.
