# CVE-2026-73498: mcp-atlassian: Arbitrary file read via missing path validation in confluence_upload_attachment

> An authenticated MCP client can read arbitrary server files and exfiltrate them as Confluence attachments due to missing path validation.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-g5r6-gv6m-f5jv, PYSEC-2026-3683

## What is CVE-2026-73498?

CVE-2026-73498 is a high-severity path traversal vulnerability in sooperset mcp-atlassian, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira). Prior to 0.22.0, confluence_upload_attachment passes its client-supplied file_path directly to open(file_path, "rb") in src/mcp_atlassian/confluence/attachments.py through _upload_attachment_direct() without calling validate_safe_path. An authenticated MCP client can read any file accessible to the server process and exfiltrate it to Confluence as an attachment. If an AI agent can be induced to call the tool through untrusted content, the same flaw can disclose server environment variables such as CONFLUENCE_API_TOKEN and other credentials. This issue is fixed in version 0.22.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-73498?

3 open source packages ship an affected version, including mcp-atlassian.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |
| `mcp-atlassian` | PyPI | All versions | 0.22.0 |

## How do I fix CVE-2026-73498?

Upgrade mcp-atlassian to 0.22.0 or later.

## Is CVE-2026-73498 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73498 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73498 and fix it if it is affected.

What it is: CVE-2026-73498 is a high-severity path traversal vulnerability in sooperset mcp-atlassian, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73498 exists.

Affected packages and fixed versions:
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0
- mcp-atlassian (PyPI): affected all versions; fixed in 0.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73498/ (Markdown: https://insights.sbomify.com/CVE-2026-73498/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73498
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73498
- OSV: https://osv.dev/vulnerability/CVE-2026-73498

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73498/
Summaries are generated and may contain mistakes; the official description above is the record.
