# CVE-2026-73499: etcd: Watch API authorization bypass via open-ended range requests

> Authenticated users with limited read permissions can bypass access controls to monitor unauthorized keys via the Watch API.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** BELL-CVE-2026-73499, BIT-etcd-2026-73499, DEBIAN-CVE-2026-73499, ECHO-b25f-a909-5944, GHSA-xg4h-6gfc-h4m8, GO-2026-6114, MINI-24x5-cj63-fjg8, MINI-395h-q4pp-c9fg, MINI-3gmw-67r3-f9vm, MINI-3j3v-v7r6-q95f, MINI-3p6j-34fw-x2m9, MINI-44vv-cqq4-2v8h, MINI-5p69-hmhw-p2f5, MINI-68g3-q8fx-jjfj, MINI-7xcx-96wc-vgp5, MINI-9rf6-qjx5-vg65, MINI-cj9c-74pw-2vf5, MINI-cr8p-cfmj-77cg, MINI-fq34-p964-f5v7, MINI-fxgf-vxfj-wx24, MINI-hwwg-pww4-52c9, MINI-m84c-pp5x-mjfc, MINI-mmxg-79j8-637r, MINI-p2fg-qqqh-29wq, MINI-pwvh-5722-4pq6, MINI-q2xg-7g9j-crx7, MINI-r3hq-pxv2-476r, MINI-rp4m-v5xf-2pmh, MINI-xmgq-mgfr-9j9w, ROOT-APP-GOBINARY-CVE-2026-73499, UBUNTU-CVE-2026-73499

## What is CVE-2026-73499?

CVE-2026-73499 is a high-severity authentication bypass vulnerability in etcd-io etcd, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

etcd is a distributed key-value store for the data of a distributed system. Prior to versions 3.5.33, 3.6.14, and 3.7.1, a user granted READ permission on a single exact key can use the Watch gRPC API with clientv3.WithFromKey() to receive watch events for every key lexicographically greater than or equal to the permitted key. In server/etcdserver/api/v3rpc/watch.go, the open-ended RangeEnd sentinel is rewritten before the RBAC permission check in server/auth/range_perm_cache.go function isRangeOpPermitted, causing the request to be treated as an exact-key watch. Range/Get and DeleteRange requests are not affected, and the issue affects only clusters with authentication enabled. This issue is fixed in versions 3.5.33, 3.6.14, and 3.7.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-73499?

8 open source packages ship an affected version, including go.etcd.io/etcd/v3, etcd and go.etcd.io/etcd/server/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.etcd.io/etcd/v3` | Go | All versions | 3.5.33 |
| `go.etcd.io/etcd/v3` | Go | All versions | 3.5.33 |
| `go.etcd.io/etcd/v3` | Go | From 3.6.0 | 3.6.14 |
| `go.etcd.io/etcd/v3` | Go | From 3.6.0 | 3.6.14 |
| `go.etcd.io/etcd/v3` | Go | From 3.7.0-alpha.0 | 3.7.1 |
| `go.etcd.io/etcd/v3` | Go | From 3.7.0-alpha.0 | 3.7.1 |
| `etcd` | Bitnami | All versions | 3.5.33, 3.6.14, 3.7.1 |
| `go.etcd.io/etcd/server/v3` | Go | All versions | 3.5.33, 3.6.14, 3.7.1 |

## How do I fix CVE-2026-73499?

Upgrade go.etcd.io/etcd/v3 to a fixed version for your release line: 3.5.33, 3.6.14 or 3.7.1.

## Is CVE-2026-73499 being exploited?

There is no known exploitation of CVE-2026-73499 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73499 and fix it if it is affected.

What it is: CVE-2026-73499 is a high-severity authentication bypass vulnerability in etcd-io etcd, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73499 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.etcd.io/etcd/v3 (Go): affected all versions; fixed in 3.5.33
- go.etcd.io/etcd/v3 (Go): affected all versions; fixed in 3.5.33
- go.etcd.io/etcd/v3 (Go): affected from 3.6.0; fixed in 3.6.14
- go.etcd.io/etcd/v3 (Go): affected from 3.6.0; fixed in 3.6.14
- go.etcd.io/etcd/v3 (Go): affected from 3.7.0-alpha.0; fixed in 3.7.1
- go.etcd.io/etcd/v3 (Go): affected from 3.7.0-alpha.0; fixed in 3.7.1
- etcd (Bitnami): affected all versions; fixed in 3.5.33, 3.6.14, 3.7.1
- go.etcd.io/etcd/server/v3 (Go): affected all versions; fixed in 3.5.33, 3.6.14, 3.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73499/ (Markdown: https://insights.sbomify.com/CVE-2026-73499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73499
- OSV: https://osv.dev/vulnerability/CVE-2026-73499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73499/
Summaries are generated and may contain mistakes; the official description above is the record.
