CVE-2026-73500 etcd: `tlsListener.acceptLoop` spawns unbounded handshake goroutines with no deadline
A network attacker can exhaust etcd memory by opening many TCP connections without completing TLS handshakes, causing cluster unavailability.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73500?
CVE-2026-73500 is a high-severity denial of service vulnerability in etcd-io etcd, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
etcd is a distributed key-value store for the data of a distributed system. Prior to versions 3.5.33, 3.6.14, and 3.7.1, a network attacker who can reach an etcd TLS listener can open many TCP connections and never send a ClientHello. In client/pkg/transport/listener_tls.go, each connection handled by tlsListener.acceptLoop spawns a goroutine that blocks indefinitely inside tls.Conn.Handshake() and remains tracked in the pending map. Unbounded goroutine and map growth can exhaust memory in the etcd process, causing loss of availability for the cluster and, when etcd backs Kubernetes, the control plane. This issue is fixed in versions 3.5.33, 3.6.14, and 3.7.1.
Weakness: CWE-770
Which versions are affected by CVE-2026-73500?
8 open source packages ship an affected version, including go.etcd.io/etcd/v3, etcd and go.etcd.io/etcd/client/pkg/v3.
| Package | Affected | Fixed in |
|---|---|---|
go.etcd.io/etcd/v3 Go | All versions | 3.5.33 |
go.etcd.io/etcd/v3 Go | All versions | 3.5.33 |
go.etcd.io/etcd/v3 Go | From 3.6.0 | 3.6.14 |
go.etcd.io/etcd/v3 Go | From 3.6.0 | 3.6.14 |
go.etcd.io/etcd/v3 Go | From 3.7.0-alpha.0 | 3.7.1 |
go.etcd.io/etcd/v3 Go | From 3.7.0-alpha.0 | 3.7.1 |
2 more packages
etcd Bitnami | All versions | 3.5.33, 3.6.14, 3.7.1 |
go.etcd.io/etcd/client/pkg/v3 Go | All versions | 3.5.33, 3.6.14, 3.7.1 |
How do I fix CVE-2026-73500?
Upgrade go.etcd.io/etcd/v3 to a fixed version for your release line: 3.5.33, 3.6.14 or 3.7.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-73500 being exploited?
There is no known exploitation of CVE-2026-73500 in the wild and no public exploit code.
Sources
Also known as AZL-95901, AZL-95907, AZL-95913, AZL-95931, AZL-95934, AZL-95937 and 326 more.