# CVE-2026-73501: kin-openapi: ValidationHandler.Load() Fail-Open Authentication Bypass via NoopAuthenticationFunc Default

> Attackers can bypass authentication in applications using kin-openapi's ValidationHandler due to a default no-op authentication function, allowing unauthorized access to protected endpoints.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLEANSTART-2026-FW53154, CLEANSTART-2026-MA90195, CLEANSTART-2026-YF58790, DEBIAN-CVE-2026-73501, GHSA-r277-6w6q-xmqw, GO-2026-6095, MINI-3vcr-xwvj-5jmj, MINI-3w25-p4wg-773x, MINI-4xx2-rxmm-prg6, MINI-5c23-97qv-cm2m, MINI-5jp4-34mf-jmjx, MINI-5q54-wc3x-mfm7, MINI-5rwv-6jpf-mcmp, MINI-6fcj-958r-2j5j, MINI-73px-9538-84mg, MINI-7796-h6r8-cqr8, MINI-7c46-fc9w-296g, MINI-8wmh-j839-h4jf, MINI-9rjg-4cv5-h473, MINI-cjv8-v6pc-vrhq, MINI-cqhq-whwv-hhjf, MINI-f2hx-m5xr-hpj9, MINI-f973-xm4c-249h, MINI-f9v7-c3pj-cxjr, MINI-g2cc-25x6-3jjc, MINI-g84c-9gvw-r96x, MINI-gjm7-936w-65fx, MINI-gqrq-68x6-h73r, MINI-gxx7-72mv-wp7g, MINI-h5v6-qjqm-fvfp, MINI-h9vp-g77r-hp7j, MINI-hrm8-292p-fhxg, MINI-j2rw-cjm2-7w25, MINI-jv97-64p2-vp4v, MINI-mm8v-hrv2-458j, MINI-mrg9-2974-hghf, MINI-p6w7-wxw5-gpp8, MINI-p78v-7jjv-p9hf, MINI-px6r-q392-rjh7, MINI-q5mj-444m-4359, MINI-qhf4-7953-5xv2, MINI-rgvv-2fj8-4pwq, MINI-rj4j-5255-h93q, MINI-v4fh-xx9j-j267, MINI-v5mv-mf6h-2r9x, MINI-v5r4-gfc9-gp9c, MINI-v8gg-wfg6-8r8f, MINI-v9q7-5cfr-6vm4, MINI-vmxw-p68h-vxqf, MINI-x2xq-w898-gq26, MINI-x54f-2vh3-477c, RHSA-2026:59028, UBUNTU-CVE-2026-73501

## What is CVE-2026-73501?

CVE-2026-73501 is a critical authentication bypass vulnerability in getkin kin-openapi, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kin-openapi is a Go project for handling OpenAPI files. Prior to 0.144.0, ValidationHandler.Load() in openapi3filter/validation_handler.go silently replaces a nil AuthenticationFunc with NoopAuthenticationFunc, which returns nil without checking credentials. This substitution causes every OpenAPI security requirement to be satisfied for unauthenticated requests when an application relies on ValidationHandler as its enforcement middleware. The no-op callback prevents the fail-closed ErrAuthenticationServiceMissing path from being reached and forwards the request to protected handlers that may require an API key, OAuth token, or another security scheme. This issue is fixed in version 0.144.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-73501?

3 open source packages ship an affected version, including github.com/getkin/kin-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.144.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.144.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.144.0 |
| `grafana13.1` | Red Hat:hummingbird:1 | All versions | 0:13.1.3-0.2.hum1 |

## How do I fix CVE-2026-73501?

Upgrade github.com/getkin/kin-openapi to 0.144.0 or later.

## Is CVE-2026-73501 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73501 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73501 and fix it if it is affected.

What it is: CVE-2026-73501 is a critical authentication bypass vulnerability in getkin kin-openapi, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73501 exists.

Affected packages and fixed versions:
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.144.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.144.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.144.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73501/ (Markdown: https://insights.sbomify.com/CVE-2026-73501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73501
- OSV: https://osv.dev/vulnerability/CVE-2026-73501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73501/
Summaries are generated and may contain mistakes; the official description above is the record.
