# CVE-2026-73502: kin-openapi openapi3filter: unauthenticated nil-pointer panic when validating a request against a `content` parameter whose media type has no schema

> An unauthenticated attacker can cause a denial of service by sending a request that triggers a nil-pointer panic in the kin-openapi library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** CLEANSTART-2026-FV65600, CLEANSTART-2026-IY00574, CLEANSTART-2026-ND84932, CLEANSTART-2026-RJ16985, DEBIAN-CVE-2026-73502, GHSA-jpcw-4wr7-c3vq, GO-2026-6112, MINI-23jc-87mc-hch5, MINI-36g2-fvf9-9mw9, MINI-3959-qfm2-j2fr, MINI-3pgp-wqgj-749f, MINI-45q2-pm5f-95qh, MINI-4765-gffw-f9jc, MINI-4934-hrxm-95w6, MINI-5p97-hpv4-rxph, MINI-72g9-crrm-9hvr, MINI-7cx9-9h8v-gr83, MINI-7fj7-vxcv-rgmr, MINI-7rwg-48xh-6hm8, MINI-847r-r9jx-j688, MINI-86g7-3vvw-rxx8, MINI-86q4-9j3c-h4cv, MINI-8jvv-9m2j-r95g, MINI-8mmx-3j96-356h, MINI-93p5-42cf-f876, MINI-9xvj-5ffr-jvv5, MINI-cgfm-rw4c-74hh, MINI-f524-4q6q-x8h3, MINI-f827-366v-m6f9, MINI-hg6x-v59w-9q2r, MINI-j275-8w5p-8pp2, MINI-jgc9-65qw-jh4j, MINI-jj6m-6pj4-v3v5, MINI-jpxp-vvhh-62gq, MINI-mhq8-9w73-f3jg, MINI-mjjg-p2vv-jcc3, MINI-mwx2-jxr5-8m9f, MINI-pwvp-c8jg-pwh6, MINI-q8wp-q3p9-wm48, MINI-qwhm-c7cj-8qjg, MINI-r286-frqp-728q, MINI-rq8f-pm5p-26xq, MINI-v482-vc9h-cg24, MINI-vm3c-pxcf-grqf, MINI-vwjh-p8g6-vfv6, MINI-w8pw-qcr8-q234, MINI-wpp5-wp62-vqqf, MINI-x7hh-8vvv-7h5h, MINI-xg46-95ph-4jch, MINI-xx68-m354-rx28, UBUNTU-CVE-2026-73502

## What is CVE-2026-73502?

CVE-2026-73502 is a medium-severity vulnerability in getkin kin-openapi, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kin-openapi is a Go project for handling OpenAPI files. From 0.2.0 until 0.144.0, openapi3filter.ValidateRequest can encounter a NULL-pointer-dereference denial of service when an operation declares a content parameter whose application/json media type has no schema. In openapi3filter/req_resp_decoder.go, the default defaultContentParameterDecoder dereferences mt.Schema.Value without checking whether mt.Schema is nil, even though doc.Validate() accepts the document under OpenAPI 3.0.x and 3.1.x. A single unauthenticated request supplying the parameter value can panic request validation, causing an aborted request with log growth in the common synchronous net/http path or a full process crash in integrations without recovery. This issue is fixed in version 0.144.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-73502?

3 open source packages ship an affected version, including github.com/getkin/kin-openapi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.144.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.144.0 |
| `github.com/getkin/kin-openapi` | Go | All versions | 0.144.0 |

## How do I fix CVE-2026-73502?

Upgrade github.com/getkin/kin-openapi to 0.144.0 or later.

## Is CVE-2026-73502 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73502 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73502 and fix it if it is affected.

What it is: CVE-2026-73502 is a medium-severity vulnerability in getkin kin-openapi, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73502 exists.

Affected packages and fixed versions:
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.144.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.144.0
- github.com/getkin/kin-openapi (Go): affected all versions; fixed in 0.144.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73502/ (Markdown: https://insights.sbomify.com/CVE-2026-73502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73502
- OSV: https://osv.dev/vulnerability/CVE-2026-73502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73502/
Summaries are generated and may contain mistakes; the official description above is the record.
