# CVE-2026-73505: Oh My Posh: Arbitrary command execution via template injection in the path segment

> An attacker can execute arbitrary OS commands by placing a malicious directory name that triggers template injection in Oh My Posh.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-6xj8-qv9j-xcjq, GO-2026-6108

## What is CVE-2026-73505?

CVE-2026-73505 is a high-severity code injection vulnerability in JanDeDobbeleer oh-my-posh, published on 13 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Oh My Posh is the most customisable and low-latency cross platform/shell prompt renderer. Prior to 29.35.1, the setStyle() function in src/segments/path.go passed pt.Path, which includes raw folder names, to template.Render, whose function map exposes cmd, so an attacker-controlled directory name containing a Go template expression could execute arbitrary operating system commands as the current user whenever the prompt rendered inside that directory or a descendant. This issue is fixed in version 29.35.1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-73505?

3 open source packages ship an affected version, including github.com/jandedobbeleer/oh-my-posh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/jandedobbeleer/oh-my-posh` | Go | All versions | 29.35.1 |
| `github.com/jandedobbeleer/oh-my-posh` | Go | All versions | 29.35.1 |
| `github.com/jandedobbeleer/oh-my-posh` | Go | All versions | 29.35.1+incompatible |

## How do I fix CVE-2026-73505?

Upgrade github.com/jandedobbeleer/oh-my-posh to a fixed version for your release line: 29.35.1 or 29.35.1+incompatible.

## Is CVE-2026-73505 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73505 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73505 and fix it if it is affected.

What it is: CVE-2026-73505 is a high-severity code injection vulnerability in JanDeDobbeleer oh-my-posh, published on 13 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73505 exists.

Affected packages and fixed versions:
- github.com/jandedobbeleer/oh-my-posh (Go): affected all versions; fixed in 29.35.1
- github.com/jandedobbeleer/oh-my-posh (Go): affected all versions; fixed in 29.35.1
- github.com/jandedobbeleer/oh-my-posh (Go): affected all versions; fixed in 29.35.1+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73505/ (Markdown: https://insights.sbomify.com/CVE-2026-73505/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73505
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73505
- OSV: https://osv.dev/vulnerability/CVE-2026-73505

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73505/
Summaries are generated and may contain mistakes; the official description above is the record.
