# CVE-2026-73506: Oh My Posh: Terminal escape sequence injection via unsanitized prompt segment data

> Attackers can inject terminal escape sequences via unsanitized prompt data to manipulate the terminal display, clipboard, or window title.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-fwjx-9p69-h25h, GO-2026-6111

## What is CVE-2026-73506?

CVE-2026-73506 is a medium-severity vulnerability in JanDeDobbeleer oh-my-posh, published on 13 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Oh My Posh is the most customisable and low-latency cross platform/shell prompt renderer. Prior to 29.35.1, write(s rune) in src/terminal/writer.go emitted attacker-controlled current directory names and Git metadata, including Commit.Subject, Commit.Author.Name, Commit.Author.Email, and RawUpstreamURL, without removing C0/C1 terminal control characters such as ESC, BEL, CSI, and OSC, allowing terminal escape sequence injection during prompt rendering that could overwrite the clipboard, spoof the prompt or screen, manipulate the window title, or disrupt the terminal. This issue is fixed in version 29.35.1.

Weakness: CWE-150 (Improper Neutralization of Escape, Meta, or Control Sequences)

## Which versions are affected by CVE-2026-73506?

3 open source packages ship an affected version, including github.com/jandedobbeleer/oh-my-posh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/jandedobbeleer/oh-my-posh` | Go | All versions | 29.35.1 |
| `github.com/jandedobbeleer/oh-my-posh` | Go | All versions | 29.35.1 |
| `github.com/jandedobbeleer/oh-my-posh` | Go | All versions | 29.35.1+incompatible |

## How do I fix CVE-2026-73506?

Upgrade github.com/jandedobbeleer/oh-my-posh to a fixed version for your release line: 29.35.1 or 29.35.1+incompatible.

## Is CVE-2026-73506 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73506 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73506 and fix it if it is affected.

What it is: CVE-2026-73506 is a medium-severity vulnerability in JanDeDobbeleer oh-my-posh, published on 13 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73506 exists.

Affected packages and fixed versions:
- github.com/jandedobbeleer/oh-my-posh (Go): affected all versions; fixed in 29.35.1
- github.com/jandedobbeleer/oh-my-posh (Go): affected all versions; fixed in 29.35.1
- github.com/jandedobbeleer/oh-my-posh (Go): affected all versions; fixed in 29.35.1+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73506/ (Markdown: https://insights.sbomify.com/CVE-2026-73506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73506
- OSV: https://osv.dev/vulnerability/CVE-2026-73506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73506/
Summaries are generated and may contain mistakes; the official description above is the record.
