# CVE-2026-73511: Auth bypass in envoy

> Attackers can bypass authentication by exploiting path parameter handling differences between Envoy and backend servers like Tomcat.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** BIT-envoy-2026-73511, GHSA-m745-gh6x-349x, MINI-fj24-9cpx-97q5, MINI-j33r-ch4m-4gxj, MINI-pv6g-4g3f-28hm, MINI-v5qx-pr5q-x7mq

## What is CVE-2026-73511?

CVE-2026-73511 is a medium-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy normally matches the raw request path, while servlet backends such as Apache Tomcat strip semicolon matrix parameters from each path segment before resolving the resource. Envoy's ignore_path_parameters_in_path_matching option instead truncates at the first semicolon and still does not match per-segment backend behavior. A remote client can use a parameterized protected segment, or a parameter on an earlier segment, to make Envoy select an unprotected fallback while the backend resolves the protected resource. The relevant scope boundary is that the bypass requires both a path-based Envoy decision and a backend that strips semicolon parameters per segment. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.

Weakness: CWE-436 (Interpretation Conflict), CWE-289 (Authentication Bypass by Alternate Name)

## Which versions are affected by CVE-2026-73511?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.36.10, 1.37.6, 1.38.4, 1.39.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-73511?

Upgrade envoy to a fixed version for your release line: 1.36.10, 1.37.6, 1.38.4 or 1.39.1.

## Is CVE-2026-73511 being exploited?

There is no known exploitation of CVE-2026-73511 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73511 and fix it if it is affected.

What it is: CVE-2026-73511 is a medium-severity authentication bypass vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73511 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.36.10, 1.37.6, 1.38.4, 1.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73511/ (Markdown: https://insights.sbomify.com/CVE-2026-73511/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73511
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73511
- OSV: https://osv.dev/vulnerability/CVE-2026-73511

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73511/
Summaries are generated and may contain mistakes; the official description above is the record.
