# CVE-2026-73513: Envoy: oghttp2 upstream trailers incorrect handling

> A use-after-free vulnerability in Envoy's optional oghttp2 codec allows remote attackers to crash the proxy via malformed HTTP/2 trailers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** BIT-envoy-2026-73513, GHSA-jjmm-fw8p-crpw, MINI-44wm-fh3g-v3c2, MINI-8fwr-r5q2-pr35, MINI-cxm4-j45m-jr5q, MINI-rf98-pvhq-qg8x

## What is CVE-2026-73513?

CVE-2026-73513 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy's optional oghttp2 upstream HTTP/2 codec accepts a response trailer HEADERS frame without END_STREAM. Envoy completes and deferred-deletes the ActiveRequest while oghttp2 keeps the stream open, leaving ClientStreamImpl with a dangling response_decoder_ reference. A later frame on the stream can dispatch through the freed object and crash the process. The relevant scope boundary is that the default nghttp2 codec rejects the malformed trailers, and the trigger is upstream-only with oghttp2 enabled. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.

Weakness: CWE-416 (Use After Free), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-73513?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.36.10, 1.37.6, 1.38.4, 1.39.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-73513?

Upgrade envoy to a fixed version for your release line: 1.36.10, 1.37.6, 1.38.4 or 1.39.1.

## Is CVE-2026-73513 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73513 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73513 and fix it if it is affected.

What it is: CVE-2026-73513 is a high-severity use after free vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73513 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.36.10, 1.37.6, 1.38.4, 1.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73513/ (Markdown: https://insights.sbomify.com/CVE-2026-73513/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73513
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73513
- OSV: https://osv.dev/vulnerability/CVE-2026-73513

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73513/
Summaries are generated and may contain mistakes; the official description above is the record.
