# CVE-2026-73548: Envoy: Cross-user response poisoning via a generic (non-WebSocket) HTTP upgrade on Envoy's shared backend pool

> An attacker can poison responses for other users by exploiting HTTP upgrade handling in Envoy's shared backend pool, requiring specific proxy configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** BIT-envoy-2026-73548, GHSA-3vhp-c83q-jqc2, MINI-4g7g-64c4-393g, MINI-m3r6-9frp-r62r, MINI-mp2h-83w7-x89h, MINI-wvwp-chhq-hc5q

## What is CVE-2026-73548?

CVE-2026-73548 is a high-severity vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy forwards data for a configured non-WebSocket HTTP upgrade before the upstream accepts the upgrade. An unauthenticated HTTP/2 client can place a complete HTTP/1.1 request in extended CONNECT data; Envoy downgrades the request, writes the data unframed to a keep-alive HTTP/1.1 upstream, and returns the socket to the shared pool while the smuggled response remains queued. A different downstream client can then receive the attacker's response. The relevant scope boundary is that webSocket upgrades, plain CONNECT, disabled backend keep-alive, per-downstream pools, and max_requests_per_connection set to 1 are not affected by the demonstrated path. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2026-73548?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.36.10, 1.37.6, 1.38.4, 1.39.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-73548?

Upgrade envoy to a fixed version for your release line: 1.36.10, 1.37.6, 1.38.4 or 1.39.1.

## Is CVE-2026-73548 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73548 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73548 and fix it if it is affected.

What it is: CVE-2026-73548 is a high-severity vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73548 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.36.10, 1.37.6, 1.38.4, 1.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73548/ (Markdown: https://insights.sbomify.com/CVE-2026-73548/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73548
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73548
- OSV: https://osv.dev/vulnerability/CVE-2026-73548

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73548/
Summaries are generated and may contain mistakes; the official description above is the record.
