# CVE-2026-73549: Denial of service in envoy

> Attackers can crash Envoy proxy instances by sending scoped IPv6 addresses in specific transparent-proxy or QUIC configurations, requiring an upgrade to fix.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** BIT-envoy-2026-73549, GHSA-jp5f-qr64-c9vw, MINI-g994-jqp7-rjcv, MINI-q5p5-39ww-2433, MINI-qv2j-92wm-vpc2, MINI-rqgj-q9wf-h8vg

## What is CVE-2026-73549?

CVE-2026-73549 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy's Utility::copyInternetAddressAndPort and QUIC client-address paths reconstruct scoped IPv6 addresses through addressAsString and Ipv6Instance. The string includes a percent scope identifier that inet_pton cannot parse, causing an exception or abort. Kernel-provided scoped IPv6 destinations in ORIGINAL_DST transparent-proxy deployments, and affected QUIC connection paths, can therefore terminate the process. The relevant scope boundary is that the HTTP use_http_header override rejects scoped addresses earlier; the advisory's crash path requires a kernel-provided original destination or the affected QUIC path. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-73549?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.36.10, 1.37.6, 1.38.4, 1.39.1 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2026-73549?

Upgrade envoy to a fixed version for your release line: 1.36.10, 1.37.6, 1.38.4 or 1.39.1.

## Is CVE-2026-73549 being exploited?

There is no known exploitation of CVE-2026-73549 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73549 and fix it if it is affected.

What it is: CVE-2026-73549 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73549 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.36.10, 1.37.6, 1.38.4, 1.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73549/ (Markdown: https://insights.sbomify.com/CVE-2026-73549/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73549
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73549
- OSV: https://osv.dev/vulnerability/CVE-2026-73549

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73549/
Summaries are generated and may contain mistakes; the official description above is the record.
