# CVE-2026-73556: vLLM: ReDoS via structured_outputs.regex in the lm-format-enforcer backend (no compile timeout) — missed sibling of GHSA-rwxx-mrjm-wc2m

> An unauthenticated attacker can cause denial of service in vLLM by submitting a catastrophic regular expression to the structured outputs endpoint.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-48jh-3gj7-fg8v, MINI-72r3-55xc-c6pj, MINI-fxw5-mhjq-jm6p, MINI-hhc6-w7j8-737j, PYSEC-2026-3933

## What is CVE-2026-73556?

CVE-2026-73556 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.26.0, the structured_outputs.regex parameter in vllm/v1/structured_output/backend_lm_format_enforcer.py is passed to lmformatenforcer.RegexParser without compile_regex_with_timeout or validation in validate_structured_output_request_lm_format_enforcer, allowing an unauthenticated /v1/completions request against the lm-format-enforcer backend to consume a CPU core and stall the structured-output engine path with a catastrophic regular expression. This issue is fixed in version 0.26.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-73556?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.26.0 |
| `vllm` | PyPI | All versions | 0.26.0 |
| `vllm` | PyPI | All versions | 0.26.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-73556?

Upgrade vllm to 0.26.0 or later.

## Is CVE-2026-73556 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73556 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73556 and fix it if it is affected.

What it is: CVE-2026-73556 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73556 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.26.0
- vllm (PyPI): affected all versions; fixed in 0.26.0
- vllm (PyPI): affected all versions; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73556/ (Markdown: https://insights.sbomify.com/CVE-2026-73556/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73556
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73556
- OSV: https://osv.dev/vulnerability/CVE-2026-73556

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73556/
Summaries are generated and may contain mistakes; the official description above is the record.
