CVE-2026-73557 vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts

Medium 6.3 Published Updated

Attackers can bypass security checks in vLLM by racing concurrent requests, potentially causing crashes or code execution when prompt embeddings are enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-73557?

CVE-2026-73557 is a medium-severity vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.

Weakness: CWE-362

Which versions are affected by CVE-2026-73557?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.21.00.26.0
vllm PyPIFrom 0.21.00.26.0
vllm PyPIFrom 0.21.00.26.0

Products include Vllm Vllm.

How do I fix CVE-2026-73557?

Upgrade vllm to 0.26.0 or later.

Is CVE-2026-73557 being exploited?

There is no known exploitation of CVE-2026-73557 in the wild and no public exploit code.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-pr7f-p5mw-fc87, MINI-j7xv-8w99-3p27, MINI-pch5-9p23-8vcq, PYSEC-2026-3938.

Is CVE-2026-73557 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free