# CVE-2026-73557: vLLM: Incomplete CVE-2025-62164 remediation can be bypassed by concurrent prompt parts

> Attackers can bypass security checks in vLLM by racing concurrent requests, potentially causing crashes or code execution when prompt embeddings are enabled.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-pr7f-p5mw-fc87, MINI-j7xv-8w99-3p27, MINI-pch5-9p23-8vcq, PYSEC-2026-3938

## What is CVE-2026-73557?

CVE-2026-73557 is a medium-severity vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. From 0.20.2rc0 until 0.26.0, safe_load_prompt_embeds in vllm/renderers/embed_utils.py uses torch.sparse.check_sparse_tensor_invariants, whose process-global save, enable, and restore state can be raced by concurrent prompt_embeds parts submitted to POST /v1/chat/completions through AsyncMultiModalItemTracker.resolve_items, asyncio.gather, and the default executor, allowing an invalid sparse tensor to reach tensor.to_dense despite the CVE-2025-62164 guard when enable_prompt_embeds is enabled. This issue is fixed in version 0.26.0.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-73557?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.21.0 | 0.26.0 |
| `vllm` | PyPI | From 0.21.0 | 0.26.0 |
| `vllm` | PyPI | From 0.21.0 | 0.26.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-73557?

Upgrade vllm to 0.26.0 or later.

## Is CVE-2026-73557 being exploited?

There is no known exploitation of CVE-2026-73557 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73557 and fix it if it is affected.

What it is: CVE-2026-73557 is a medium-severity vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73557 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.21.0; fixed in 0.26.0
- vllm (PyPI): affected from 0.21.0; fixed in 0.26.0
- vllm (PyPI): affected from 0.21.0; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73557/ (Markdown: https://insights.sbomify.com/CVE-2026-73557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73557
- OSV: https://osv.dev/vulnerability/CVE-2026-73557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73557/
Summaries are generated and may contain mistakes; the official description above is the record.
