# CVE-2026-73558: vLLM: Cross-User Data Leak Vulnerability

> An integer overflow in vLLM allows attackers to read other users' inference results via batched requests.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-7m6h-x95x-82q5, MINI-5654-wgg2-f6c6, MINI-7hhv-gr99-276x, MINI-qmmq-rx4c-rjgq, PYSEC-2026-3935

## What is CVE-2026-73558?

CVE-2026-73558 is a medium-severity vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.27.0, an integer overflow in blockIdx.x * 2 * d in activation_kernels.cu can cause act_and_mul_kernel to consume another batched user's input, allowing a request processed in the same inference batch to receive a partial or complete copy of another user's inference result. This issue is fixed in version 0.27.0.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-73558?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.27.0 |
| `vllm` | PyPI | All versions | 0.27.0 |
| `vllm` | PyPI | All versions | 0.27.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-73558?

Upgrade vllm to 0.27.0 or later.

## Is CVE-2026-73558 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73558 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73558 and fix it if it is affected.

What it is: CVE-2026-73558 is a medium-severity vulnerability in Vllm Vllm, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73558 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.27.0
- vllm (PyPI): affected all versions; fixed in 0.27.0
- vllm (PyPI): affected all versions; fixed in 0.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73558/ (Markdown: https://insights.sbomify.com/CVE-2026-73558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73558
- OSV: https://osv.dev/vulnerability/CVE-2026-73558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73558/
Summaries are generated and may contain mistakes; the official description above is the record.
