# CVE-2026-73559: vLLM: Completion prompt lists fan out into unbounded engine requests

> An authenticated user can cause resource exhaustion and denial of service by submitting a completion request with an unbounded list of prompts.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-87x5-vmc3-756j, MINI-669x-hpx7-64m9, MINI-68hr-m52v-8fr2, MINI-vh25-68rj-6x85, PYSEC-2026-3704

## What is CVE-2026-73559?

CVE-2026-73559 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. From 0.19.0 until 0.26.0, the /v1/completions CompletionRequest.prompt field in vllm/entrypoints/openai/completion/protocol.py accepts an unbounded list[str] or list[list[int]], prompt_to_seq() in vllm/renderers/inputs/preprocess.py and OnlineRenderer.preprocess_completion() in vllm/renderers/online_renderer.py expand every element, and vllm/entrypoints/openai/completion/serving.py creates one engine generator and response slot per prompt, allowing an authenticated API client to exhaust CPU, memory, async scheduling capacity, engine request slots, and response buffering with one request. This issue is fixed in version 0.26.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-73559?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.19.0 | 0.26.0 |
| `vllm` | PyPI | From 0.19.0 | 0.26.0 |
| `vllm` | PyPI | From 0.19.0 | 0.26.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-73559?

Upgrade vllm to 0.26.0 or later.

## Is CVE-2026-73559 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73559 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73559 and fix it if it is affected.

What it is: CVE-2026-73559 is a medium-severity denial of service vulnerability in Vllm Vllm, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73559 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.19.0; fixed in 0.26.0
- vllm (PyPI): affected from 0.19.0; fixed in 0.26.0
- vllm (PyPI): affected from 0.19.0; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73559/ (Markdown: https://insights.sbomify.com/CVE-2026-73559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73559
- OSV: https://osv.dev/vulnerability/CVE-2026-73559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73559/
Summaries are generated and may contain mistakes; the official description above is the record.
