# CVE-2026-73560: vLLM: SSRF + arbitrary local file read in MiMoV2OmniMultiModalProcessor `_fetch_image` and audio loader bypass MediaConnector protections

> Attackers can bypass media protections to perform server-side requests and read arbitrary local files in vLLM.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-4hhp-h66f-j5j7, MINI-6rm2-m357-88xv, MINI-mjp4-p299-vcwj, MINI-v5jf-vvpw-r25v, PYSEC-2026-3934, openSUSE-SU-2026:12185-1

## What is CVE-2026-73560?

CVE-2026-73560 is a medium-severity server-side request forgery vulnerability in Vllm Vllm, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. Prior to 0.26.0, the MiMoV2OmniMultiModalProcessor in vllm/transformers_utils/processors/mimo_v2_omni.py passes attacker-controlled image and audio strings through _fetch_image, requests.get, and Image.open instead of MediaConnector, bypassing allowed_media_domains and allowed_local_media_path protections and allowing server-side requests and reads of arbitrary files accessible to the vLLM process. This issue is fixed in version 0.26.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-73560?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.26.0 |
| `vllm` | PyPI | All versions | 0.26.0 |
| `vllm` | PyPI | All versions | 0.26.0 |
| `python-vllm` | openSUSE:Tumbleweed | All versions | 0.32.0-1.1 |

Products: Vllm Vllm.

## How do I fix CVE-2026-73560?

Upgrade vllm to 0.26.0 or later.

## Is CVE-2026-73560 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73560 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73560 and fix it if it is affected.

What it is: CVE-2026-73560 is a medium-severity server-side request forgery vulnerability in Vllm Vllm, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73560 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.26.0
- vllm (PyPI): affected all versions; fixed in 0.26.0
- vllm (PyPI): affected all versions; fixed in 0.26.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73560/ (Markdown: https://insights.sbomify.com/CVE-2026-73560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73560
- OSV: https://osv.dev/vulnerability/CVE-2026-73560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73560/
Summaries are generated and may contain mistakes; the official description above is the record.
