# CVE-2026-73569: fast-xml-parser: Repeated DOCTYPE declarations reset entity expansion limits

> A crafted XML document can cause excessive CPU and memory usage in fast-xml-parser by resetting entity expansion limits, leading to denial of service.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-73569, GHSA-8r6m-32jq-jx6q, UBUNTU-CVE-2026-73569

## What is CVE-2026-73569?

CVE-2026-73569 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-xml-parser allows users to process XML from JS object without C/C++ based libraries or callbacks. From 5.9.3 until 5.10.1, src/xmlparser/OrderedObjParser.js processes multiple DOCTYPE declarations within a single XML document and passes each declaration's entities through addInputEntities(). addInputEntities() resets maxTotalExpansions and maxExpandedLength every time it is called, allowing additional DOCTYPE declarations to repeatedly reset the configured entity-expansion limits during one parse operation. A crafted XML document can then cause excessive CPU use, event-loop blocking, memory exhaustion, and process termination. This issue is fixed in version 5.10.1.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2026-73569?

2 open source packages ship an affected version, including fast-xml-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-xml-parser` | npm | From 5.9.3 | 5.10.1 |
| `fast-xml-parser` | npm | From 5.9.3 | 5.10.1 |

## How do I fix CVE-2026-73569?

Upgrade fast-xml-parser to 5.10.1 or later.

## Is CVE-2026-73569 being exploited?

There is no known exploitation of CVE-2026-73569 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73569 and fix it if it is affected.

What it is: CVE-2026-73569 is a high-severity denial of service vulnerability in NaturalIntelligence fast-xml-parser, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73569 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-xml-parser (npm): affected from 5.9.3; fixed in 5.10.1
- fast-xml-parser (npm): affected from 5.9.3; fixed in 5.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73569/ (Markdown: https://insights.sbomify.com/CVE-2026-73569/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73569
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73569
- OSV: https://osv.dev/vulnerability/CVE-2026-73569

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73569/
Summaries are generated and may contain mistakes; the official description above is the record.
