CVE-2026-73581 Apache Tomcat: OpenSSL and OpenSSL-FFM TLS implementations ignore CRLs when certificate uses a keystore
Apache Tomcat ignores Certificate Revocation Lists when using OpenSSL with keystore certificates, allowing revoked certificates to be accepted.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73581?
CVE-2026-73581 is a medium-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Check for Certificate Revocation vulnerability in Apache Tomcat. Both the OpenSSL and OpenSSL-FFM TLS implementations ignore CRLs when certificate uses a keystore.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0-M1 through 9.0.121.
The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.59, 9.0.122, which fixes the issue.
Weakness: CWE-299
Which versions are affected by CVE-2026-73581?
1 open source package ship an affected version, including tomcat.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | From 8.5.0 | 9.0.45, 10.1.60, 11.0.26, 9.0.122 |
How do I fix CVE-2026-73581?
Upgrade tomcat to a fixed version for your release line: 9.0.45, 10.1.60, 11.0.26 or 9.0.122.
Is CVE-2026-73581 being exploited?
There is no known exploitation of CVE-2026-73581 in the wild and no public exploit code.
Sources
Also known as BIT-tomcat-2026-73581, DEBIAN-CVE-2026-73581, GHSA-cf68-55f3-8gfw, MINI-23vf-7r6q-gcfm, MINI-27mf-hmgc-6mc6, MINI-wmvp-43vj-p9hq and 1 more.