{"answers":{"affected":"1 open source package ship an affected version, including tomcat.","exploited":"There is no known exploitation of CVE-2026-73581 in the wild and no public exploit code.","fix":"Upgrade tomcat to a fixed version for your release line: 9.0.45, 10.1.60, 11.0.26 or 9.0.122.","what":"CVE-2026-73581 is a medium-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73581 and fix it if it is affected.\n\nWhat it is: CVE-2026-73581 is a medium-severity vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73581 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tomcat (Bitnami): affected from 8.5.0; fixed in 9.0.45, 10.1.60, 11.0.26, 9.0.122\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73581/ (Markdown: https://insights.sbomify.com/CVE-2026-73581/index.md)","id":"CVE-2026-73581","markdown":"https://insights.sbomify.com/CVE-2026-73581/index.md","name":"CVE-2026-73581","record":{"aliases":["BIT-tomcat-2026-73581","DEBIAN-CVE-2026-73581","GHSA-cf68-55f3-8gfw","MINI-23vf-7r6q-gcfm","MINI-27mf-hmgc-6mc6","MINI-wmvp-43vj-p9hq","UBUNTU-CVE-2026-73581"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Tomcat","requires_auth":"none","summary":"Apache Tomcat ignores Certificate Revocation Lists when using OpenSSL with keystore certificates, allowing revoked certificates to be accepted.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-299","name":"Improper Check for Certificate Revocation"}],"description":"Improper Check for Certificate Revocation vulnerability in Apache Tomcat. Both the OpenSSL and OpenSSL-FFM TLS implementations ignore CRLs when certificate uses a keystore.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0-M1 through 9.0.121.\n\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected.\n\nUsers are recommended to upgrade to version 11.0.26, 10.1.59, 9.0.122, which fixes the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Tomcat: OpenSSL and OpenSSL-FFM TLS implementations ignore CRLs when certificate uses a keystore","id":"CVE-2026-73581","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Deserialization in Red Hat Enterprise Linux 10","id":"CVE-2026-73583"},"packages":[{"ecosystem":"Bitnami","fixed":["9.0.45","10.1.60","11.0.26","9.0.122"],"introduced":["8.5.0","10.1.0","11.0.0","9.0.0"],"last_affected":[],"package":"tomcat","purl":"pkg:bitnami/tomcat","source":"BIT-tomcat-2026-73581"}],"prev":{"headline":"Apache Syncope: Non-recursive Any search could skip Realms restrictions","id":"CVE-2026-73579"},"products":["Apache Tomcat"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["Apache Software Foundation"]},"summary":"Apache Tomcat ignores Certificate Revocation Lists when using OpenSSL with keystore certificates, allowing revoked certificates to be accepted.","url":"https://insights.sbomify.com/CVE-2026-73581/"}