# CVE-2026-73620: GitPython before 3.1.57 Arbitrary File Overwrite and Read

> Attackers can exploit unsafe option forwarding in GitPython to overwrite or read arbitrary files via crafted repository operations.

- **Severity:** High 7.2 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-73620, ECHO-9cab-61a6-aebd, ECHO-de72-db5b-dfba, GHSA-3f7w-8rr8-f37f, GHSA-mhfq-f35q-x62m, MINI-57f8-3mmj-2q46, MINI-5q3f-9p83-4355, MINI-6qp3-7fcv-7rvv, MINI-84rf-r45g-73g3, MINI-fh7v-pmm4-vf5g, PYSEC-2026-3949, ROOT-APP-PYPI-GHSA-3f7w-8rr8-f37f, UBUNTU-CVE-2026-73620

## What is CVE-2026-73620?

CVE-2026-73620 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitPython before 3.1.57 fails to guard git option forwarding in IndexFile.checkout() and TagReference.create(), allowing attackers to pass unsafe options via kwargs. Attackers can use --prefix to overwrite arbitrary files with repository content or -F to read arbitrary files returned in-band.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-73620?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.57 |
| `gitpython` | PyPI | All versions | 3.1.57 |
| `GitPython` | PyPI | All versions | 3.1.57 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-73620?

Upgrade gitpython to 3.1.57 or later.

## Is CVE-2026-73620 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73620 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73620 and fix it if it is affected.

What it is: CVE-2026-73620 is a high-severity path traversal vulnerability in gitpython-developers GitPython, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73620 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.57
- gitpython (PyPI): affected all versions; fixed in 3.1.57
- GitPython (PyPI): affected all versions; fixed in 3.1.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73620/ (Markdown: https://insights.sbomify.com/CVE-2026-73620/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73620
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73620
- OSV: https://osv.dev/vulnerability/CVE-2026-73620

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73620/
Summaries are generated and may contain mistakes; the official description above is the record.
