{"answers":{"affected":"5 open source packages ship an affected version, including jupyterlab.","exploited":"There is no known exploitation of CVE-2026-73626 in the wild and no public exploit code.","fix":"Upgrade jupyterlab to a fixed version for your release line: 4.5.10 or 4.6.2.","what":"CVE-2026-73626 is a high-severity authentication bypass vulnerability in jupyterlab, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73626 and fix it if it is affected.\n\nWhat it is: CVE-2026-73626 is a high-severity authentication bypass vulnerability in jupyterlab, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73626 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jupyterlab (Bitnami): affected all versions; fixed in 4.5.10, 4.6.2\n- jupyterlab (PyPI): affected all versions; fixed in 4.5.10\n- jupyterlab (PyPI): affected all versions; fixed in 4.5.10\n- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.2\n- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73626/ (Markdown: https://insights.sbomify.com/CVE-2026-73626/index.md)","id":"CVE-2026-73626","markdown":"https://insights.sbomify.com/CVE-2026-73626/index.md","name":"CVE-2026-73626","record":{"aliases":["BIT-jupyterlab-2026-73626","CLEANSTART-2026-LY16502","DEBIAN-CVE-2026-73626","GHSA-r336-hqvq-mfjh","GHSA-whvh-wf3x-g77j","OESA-2026-4167","UBUNTU-CVE-2026-73626"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JupyterLab","requires_auth":"low_privilege","summary":"Attackers can bypass extension allowlist/blocklist checks in JupyterLab when custom integrations call install() directly with untrusted input.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"JupyterLab versions \u003e=4.6.0,\u003c=4.6.1 and \u003c=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager","id":"CVE-2026-73626","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":5,"n_references":2,"next":{"headline":"JupyterLab 4.6.0 Plugin Manager Lock-Rule Enforcement Bypass","id":"CVE-2026-73627"},"packages":[{"ecosystem":"Bitnami","fixed":["4.5.10","4.6.2"],"introduced":["0","4.6.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:bitnami/jupyterlab","source":"BIT-jupyterlab-2026-73626"},{"ecosystem":"PyPI","fixed":["4.5.10"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":null,"source":"GHSA-whvh-wf3x-g77j"},{"ecosystem":"PyPI","fixed":["4.5.10"],"introduced":["0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"GHSA-whvh-wf3x-g77j"},{"ecosystem":"PyPI","fixed":["4.6.2"],"introduced":["4.6.0"],"last_affected":[],"package":"jupyterlab","purl":null,"source":"GHSA-whvh-wf3x-g77j"},{"ecosystem":"PyPI","fixed":["4.6.2"],"introduced":["4.6.0"],"last_affected":[],"package":"jupyterlab","purl":"pkg:pypi/jupyterlab","source":"GHSA-whvh-wf3x-g77j"}],"prev":{"headline":"GitPython before 3.1.54 Remote Code Execution via kwarg value smuggling","id":"CVE-2026-73625"},"products":["jupyterlab"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-28","vendors":["jupyterlab"]},"summary":"Attackers can bypass extension allowlist/blocklist checks in JupyterLab when custom integrations call install() directly with untrusted input.","url":"https://insights.sbomify.com/CVE-2026-73626/"}