# CVE-2026-73626: JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager

> Attackers can bypass extension allowlist/blocklist checks in JupyterLab when custom integrations call install() directly with untrusted input.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** BIT-jupyterlab-2026-73626, CLEANSTART-2026-LY16502, DEBIAN-CVE-2026-73626, GHSA-r336-hqvq-mfjh, GHSA-whvh-wf3x-g77j, OESA-2026-4167, UBUNTU-CVE-2026-73626

## What is CVE-2026-73626?

CVE-2026-73626 is a high-severity authentication bypass vulnerability in jupyterlab, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-73626?

5 open source packages ship an affected version, including jupyterlab.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab` | Bitnami | All versions | 4.5.10, 4.6.2 |
| `jupyterlab` | PyPI | All versions | 4.5.10 |
| `jupyterlab` | PyPI | All versions | 4.5.10 |
| `jupyterlab` | PyPI | From 4.6.0 | 4.6.2 |
| `jupyterlab` | PyPI | From 4.6.0 | 4.6.2 |

## How do I fix CVE-2026-73626?

Upgrade jupyterlab to a fixed version for your release line: 4.5.10 or 4.6.2.

## Is CVE-2026-73626 being exploited?

There is no known exploitation of CVE-2026-73626 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73626 and fix it if it is affected.

What it is: CVE-2026-73626 is a high-severity authentication bypass vulnerability in jupyterlab, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73626 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterlab (Bitnami): affected all versions; fixed in 4.5.10, 4.6.2
- jupyterlab (PyPI): affected all versions; fixed in 4.5.10
- jupyterlab (PyPI): affected all versions; fixed in 4.5.10
- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.2
- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73626/ (Markdown: https://insights.sbomify.com/CVE-2026-73626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73626
- OSV: https://osv.dev/vulnerability/CVE-2026-73626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73626/
Summaries are generated and may contain mistakes; the official description above is the record.
