# CVE-2026-73627: JupyterLab 4.6.0 Plugin Manager Lock-Rule Enforcement Bypass

> Authenticated users can bypass administrator plugin lock rules in JupyterLab, enabling or disabling restricted plugins and circumventing security hardening measures.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-jupyterlab-2026-73627, CLEANSTART-2026-ED51951, DEBIAN-CVE-2026-73627, GHSA-fpf6-h6p9-9rjr, GHSA-h5v5-8746-g7mm, MINI-hxg6-j69m-wvr6, UBUNTU-CVE-2026-73627

## What is CVE-2026-73627?

CVE-2026-73627 is a medium-severity vulnerability in jupyterlab, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

JupyterLab (pip package 'jupyterlab') versions >=4.1.0,<=4.5.9 and >=4.6.0,<=4.6.1 contain a plugin manager lock-rule enforcement bypass. Two server-side enforcement gaps allow an authenticated user to circumvent administrator lock rules by making direct requests to the /lab/api/plugins endpoint, enabling or disabling plugins that were locked — including child plugins of multi-plugin extensions and plugins locked via the 'lock all' mechanism. This can impact data integrity and bypass hardening or restrictions (e.g., download/upload limits) implemented through locked plugins. Fixed in versions 4.6.2 and 4.5.10.

Weakness: CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2026-73627?

5 open source packages ship an affected version, including jupyterlab.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab` | Bitnami | From 4.1.0 | 4.5.10, 4.6.2 |
| `jupyterlab` | PyPI | From 4.1.0 | 4.5.10 |
| `jupyterlab` | PyPI | From 4.1.0 | 4.5.10 |
| `jupyterlab` | PyPI | From 4.6.0 | 4.6.2 |
| `jupyterlab` | PyPI | From 4.6.0 | 4.6.2 |

## How do I fix CVE-2026-73627?

Upgrade jupyterlab to a fixed version for your release line: 4.5.10 or 4.6.2.

## Is CVE-2026-73627 being exploited?

There is no known exploitation of CVE-2026-73627 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73627 and fix it if it is affected.

What it is: CVE-2026-73627 is a medium-severity vulnerability in jupyterlab, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73627 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyterlab (Bitnami): affected from 4.1.0; fixed in 4.5.10, 4.6.2
- jupyterlab (PyPI): affected from 4.1.0; fixed in 4.5.10
- jupyterlab (PyPI): affected from 4.1.0; fixed in 4.5.10
- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.2
- jupyterlab (PyPI): affected from 4.6.0; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73627/ (Markdown: https://insights.sbomify.com/CVE-2026-73627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73627
- OSV: https://osv.dev/vulnerability/CVE-2026-73627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73627/
Summaries are generated and may contain mistakes; the official description above is the record.
