CVE-2026-73633 Apache Struts: Unbounded read of a JSON request body
Attackers can cause denial of service by sending large JSON requests to Apache Struts applications using the optional JSON plugin.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-73633?
CVE-2026-73633 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Uncontrolled resource consumption vulnerability in the JSON plugin of Apache Struts. When an application is configured to populate actions from a JSON request body, the plugin reads that body into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. The plugin's configurable JSON input length limit does not bound this read. The JSON plugin is an optional component; applications that do not use it, or use it without enabling JSON request-body handling, are not affected.
This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1.
Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.
Weakness: CWE-400
Which versions are affected by CVE-2026-73633?
It affects 1 product.
Products include Apache Struts.
How do I fix CVE-2026-73633?
No fix has been published for CVE-2026-73633 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-73633 being exploited?
There is no known exploitation of CVE-2026-73633 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-335q-cpqh-m68h.