# CVE-2026-73633: Apache Struts: Unbounded read of a JSON request body

> Attackers can cause denial of service by sending large JSON requests to Apache Struts applications using the optional JSON plugin.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-335q-cpqh-m68h

## What is CVE-2026-73633?

CVE-2026-73633 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled resource consumption vulnerability in the JSON plugin of Apache Struts. When an application is configured to populate actions from a JSON request body, the plugin reads that body into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. The plugin's configurable JSON input length limit does not bound this read. The JSON plugin is an optional component; applications that do not use it, or use it without enabling JSON request-body handling, are not affected.

This issue affects Apache Struts: from 2.1.8 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1.

Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-73633?

It affects 1 product.


Products: Apache Struts.

## How do I fix CVE-2026-73633?

No fix has been published for CVE-2026-73633 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73633 being exploited?

There is no known exploitation of CVE-2026-73633 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-73633（S2-072）概念验证代码 (github_poc): https://github.com/CuteeCat/CVE-2026-73633

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73633 and fix it if it is affected.

What it is: CVE-2026-73633 is a high-severity denial of service vulnerability in Apache Struts, published on 14 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73633 in the wild and no public exploit code.

Affected product: Apache Struts. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73633/ (Markdown: https://insights.sbomify.com/CVE-2026-73633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73633
- OSV: https://osv.dev/vulnerability/CVE-2026-73633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73633/
Summaries are generated and may contain mistakes; the official description above is the record.
