# CVE-2026-73634: Apache Struts: Unbounded read of a Content Security Policy violation report

> Attackers can exhaust server memory via unbounded CSP report submissions, causing denial of service in Apache Struts applications with this feature enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-wxrh-8hrv-h99q

## What is CVE-2026-73634?

CVE-2026-73634 is a high-severity denial of service vulnerability in Apache Struts, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution maps no such endpoint by default; applications that do not collect violation reports are not affected.

This issue affects Apache Struts: from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1.

Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-73634?

It affects 1 product.


Products: Apache Struts.

## How do I fix CVE-2026-73634?

No fix has been published for CVE-2026-73634 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-73634 being exploited?

There is no known exploitation of CVE-2026-73634 in the wild and no public exploit code.

## Other vulnerabilities in Apache Struts

- [CVE-2020-17530](https://insights.sbomify.com/CVE-2020-17530/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-9791](https://insights.sbomify.com/CVE-2017-9791/): Apache Struts 1 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2017-5638](https://insights.sbomify.com/CVE-2017-5638/): Apache Struts Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2012-0391](https://insights.sbomify.com/CVE-2012-0391/): Apache Struts 2 Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2018-11776](https://insights.sbomify.com/CVE-2018-11776/): Apache Struts Remote Code Execution (high 8.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73634 and fix it if it is affected.

What it is: CVE-2026-73634 is a high-severity denial of service vulnerability in Apache Struts, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73634 in the wild and no public exploit code.

Affected product: Apache Struts. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73634/ (Markdown: https://insights.sbomify.com/CVE-2026-73634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73634
- OSV: https://osv.dev/vulnerability/CVE-2026-73634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73634/
Summaries are generated and may contain mistakes; the official description above is the record.
