CVE-2026-73635 Apache Struts: Unbounded growth of localized-text caches driven by the request locale
Unauthenticated attackers can exhaust Java heap memory by manipulating request locales, causing denial of service in Apache Struts applications without fixed locale configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-73635?
CVE-2026-73635 is a high-severity denial of service vulnerability in Apache Struts, published on 15 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Allocation of resources without limits or throttling vulnerability in Apache Struts. When no fixed locale is configured, the locale used for localized-text lookups is taken from the incoming request, allowing an unauthenticated remote client to cause the framework's internal localized-text caches to grow without bound and exhaust the Java heap, denying service to other users. Applications that configure a fixed locale are not affected.
This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1.
Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.
Weakness: CWE-770
Which versions are affected by CVE-2026-73635?
It affects 1 product.
Products include Apache Struts.
How do I fix CVE-2026-73635?
No fix has been published for CVE-2026-73635 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-73635 being exploited?
There is no known exploitation of CVE-2026-73635 in the wild and no public exploit code.
Other vulnerabilities in Apache Struts
Sources
Also known as GHSA-prrh-5r25-ch75.