{"answers":{"affected":"2 open source packages ship an affected version, including js-yaml.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73643 exists.","fix":"Upgrade js-yaml to 5.2.2 or later.","what":"CVE-2026-73643 is a high-severity denial of service vulnerability in nodeca js-yaml, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73643 and fix it if it is affected.\n\nWhat it is: CVE-2026-73643 is a high-severity denial of service vulnerability in nodeca js-yaml, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73643 exists.\n\nAffected packages and fixed versions:\n- js-yaml (npm): affected from 5.0.0; fixed in 5.2.2\n- js-yaml (npm): affected from 5.0.0; fixed in 5.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73643/ (Markdown: https://insights.sbomify.com/CVE-2026-73643/index.md)","id":"CVE-2026-73643","markdown":"https://insights.sbomify.com/CVE-2026-73643/index.md","name":"CVE-2026-73643","record":{"aliases":["CLSA-2026-1792473248","GHSA-pm4m-ph32-ghv5","ROOT-APP-NPM-CVE-2026-73643","ROOT-APP-NPM-GHSA-pm4m-ph32-ghv5","UBUNTU-CVE-2026-73643"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript YAML parser","requires_auth":"none","summary":"Attackers can cause denial of service by submitting small YAML inputs that trigger exponential parsing time, blocking the Node.js event loop.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"js-yaml is a JavaScript YAML parser and dumper. From 5.0.0 until 5.2.2, parsing a small YAML document can take exponential time when an application calls load() or loadAll() on untrusted input. In src/parser/parser.ts, readFlowCollection uses restoreState and calls parseNode a second time when a flow-sequence entry is recognized as a key: value pair. If the key is a nested flow sequence of the same shape, every level is parsed twice, causing O(2^n) work and allowing an input under 200 bytes to keep one CPU busy for minutes, block the Node.js event loop, and stall the process. No anchors, aliases, merges, tags, or nondefault options are required. This issue is fixed in version 5.2.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"js-yaml: Exponential parsing time in the flow collections leads to denial of service","id":"CVE-2026-73643","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"OpenDJ SASL PLAIN authzid bypassing the proxy ACI scope check","id":"CVE-2026-73644"},"packages":[{"ecosystem":"npm","fixed":["5.2.2"],"introduced":["5.0.0"],"last_affected":[],"package":"js-yaml","purl":null,"source":"GHSA-pm4m-ph32-ghv5"},{"ecosystem":"npm","fixed":["5.2.2"],"introduced":["5.0.0"],"last_affected":[],"package":"js-yaml","purl":"pkg:npm/js-yaml","source":"GHSA-pm4m-ph32-ghv5"}],"prev":{"headline":"Path Traversal in Dayforce ESS Excelity","id":"CVE-2026-73642"},"products":["js-yaml"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-14","vendors":["nodeca"]},"summary":"Attackers can cause denial of service by submitting small YAML inputs that trigger exponential parsing time, blocking the Node.js event loop.","url":"https://insights.sbomify.com/CVE-2026-73643/"}