# CVE-2026-73643: js-yaml: Exponential parsing time in the flow collections leads to denial of service

> Attackers can cause denial of service by submitting small YAML inputs that trigger exponential parsing time, blocking the Node.js event loop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** CLSA-2026-1792473248, GHSA-pm4m-ph32-ghv5, ROOT-APP-NPM-CVE-2026-73643, ROOT-APP-NPM-GHSA-pm4m-ph32-ghv5, UBUNTU-CVE-2026-73643

## What is CVE-2026-73643?

CVE-2026-73643 is a high-severity denial of service vulnerability in nodeca js-yaml, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-yaml is a JavaScript YAML parser and dumper. From 5.0.0 until 5.2.2, parsing a small YAML document can take exponential time when an application calls load() or loadAll() on untrusted input. In src/parser/parser.ts, readFlowCollection uses restoreState and calls parseNode a second time when a flow-sequence entry is recognized as a key: value pair. If the key is a nested flow sequence of the same shape, every level is parsed twice, causing O(2^n) work and allowing an input under 200 bytes to keep one CPU busy for minutes, block the Node.js event loop, and stall the process. No anchors, aliases, merges, tags, or nondefault options are required. This issue is fixed in version 5.2.2.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-73643?

2 open source packages ship an affected version, including js-yaml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-yaml` | npm | From 5.0.0 | 5.2.2 |
| `js-yaml` | npm | From 5.0.0 | 5.2.2 |

## How do I fix CVE-2026-73643?

Upgrade js-yaml to 5.2.2 or later.

## Is CVE-2026-73643 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73643 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73643 and fix it if it is affected.

What it is: CVE-2026-73643 is a high-severity denial of service vulnerability in nodeca js-yaml, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73643 exists.

Affected packages and fixed versions:
- js-yaml (npm): affected from 5.0.0; fixed in 5.2.2
- js-yaml (npm): affected from 5.0.0; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73643/ (Markdown: https://insights.sbomify.com/CVE-2026-73643/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73643
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73643
- OSV: https://osv.dev/vulnerability/CVE-2026-73643

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73643/
Summaries are generated and may contain mistakes; the official description above is the record.
