{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.opendj:opendj-server-legacy.","exploited":"There is no known exploitation of CVE-2026-73644 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.opendj:opendj-server-legacy to 5.1.2 or later.","what":"CVE-2026-73644 is a critical authentication bypass vulnerability in OpenIdentityPlatform OpenDJ, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73644 and fix it if it is affected.\n\nWhat it is: CVE-2026-73644 is a critical authentication bypass vulnerability in OpenIdentityPlatform OpenDJ, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-73644 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.opendj:opendj-server-legacy (Maven): affected all versions; fixed in 5.1.2\n- org.openidentityplatform.opendj:opendj-server-legacy (Maven): affected all versions; fixed in 5.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73644/ (Markdown: https://insights.sbomify.com/CVE-2026-73644/index.md)","id":"CVE-2026-73644","markdown":"https://insights.sbomify.com/CVE-2026-73644/index.md","name":"CVE-2026-73644","record":{"aliases":["GHSA-p279-2cqp-84jg"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LDAP directory server","requires_auth":"low_privilege","summary":"An authenticated user with PROXIED_AUTH privilege can impersonate any non-root user in OpenDJ, bypassing proxy ACI restrictions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"OpenDJ is an LDAPv3 compliant directory service. Prior to 5.1.2, the SASL PLAIN authorization identity path in opendj-server-legacy/src/main/java/org/opends/server/extensions/PlainSASLMechanismHandler.java checked the PROXIED_AUTH privilege but did not evaluate the mayProxy proxy ACI scope when an authzid resolved to a different user. Both dn: and u: or bare authzid forms could therefore let an authenticated account holding PROXIED_AUTH assume any resolvable non-root identity outside the identities permitted by its proxy ACI. The fix returns INVALID_CREDENTIALS (49) before password verification when the target authorization identity is not permitted. This issue is fixed in version 5.1.2.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenDJ SASL PLAIN authzid bypassing the proxy ACI scope check","id":"CVE-2026-73644","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"ERC7984ERC20Wrapper: once a wrapper is filled, subsequent wrap requests do not revert and result in loss of funds.","id":"CVE-2026-73645"},"packages":[{"ecosystem":"Maven","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.opendj:opendj-server-legacy","purl":null,"source":"GHSA-p279-2cqp-84jg"},{"ecosystem":"Maven","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.opendj:opendj-server-legacy","purl":"pkg:maven/org.openidentityplatform.opendj/opendj-server-legacy","source":"GHSA-p279-2cqp-84jg"}],"prev":{"headline":"js-yaml: Exponential parsing time in the flow collections leads to denial of service","id":"CVE-2026-73643"},"products":["OpenDJ"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["OpenIdentityPlatform"]},"summary":"An authenticated user with PROXIED_AUTH privilege can impersonate any non-root user in OpenDJ, bypassing proxy ACI restrictions.","url":"https://insights.sbomify.com/CVE-2026-73644/"}