{"answers":{"affected":"2 open source packages ship an affected version, including quasar.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73647 exists.","fix":"Upgrade quasar to 2.22.0 or later.","what":"CVE-2026-73647 is a medium-severity code injection vulnerability in quasarframework quasar, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-73647 and fix it if it is affected.\n\nWhat it is: CVE-2026-73647 is a medium-severity code injection vulnerability in quasarframework quasar, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73647 exists.\n\nAffected packages and fixed versions:\n- quasar (npm): affected all versions; fixed in 2.22.0\n- quasar (npm): affected all versions; fixed in 2.22.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-73647/ (Markdown: https://insights.sbomify.com/CVE-2026-73647/index.md)","id":"CVE-2026-73647","markdown":"https://insights.sbomify.com/CVE-2026-73647/index.md","name":"CVE-2026-73647","record":{"aliases":["GHSA-3r53-75j5-3g7j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Vue.js UI framework","requires_auth":"none","summary":"Attackers can pollute Object.prototype via the extend utility, leading to code execution or denial of service in applications using Quasar Framework.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to 2.22.0, the public extend() utility in ui/src/utils/extend/extend.js recursively copied attacker-controlled object keys during extend(true, target, source) deep merges without rejecting an own __proto__ property. The merge could descend into the prototype object and write attacker-controlled properties to Object.prototype in the same JavaScript process. Applications that passed user-controlled or partially user-controlled objects to extend() could experience logic bypass, unsafe default-option injection, denial of service, or other application-specific impact when polluted properties were later consumed. This issue is fixed in version 2.22.0.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Quasar Framework: Prototype pollution in Quasar extend() utility","id":"CVE-2026-73647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"rails-html-sanitizer: Possible XSS vulnerability with certain configurations","id":"CVE-2026-73648"},"packages":[{"ecosystem":"npm","fixed":["2.22.0"],"introduced":["0"],"last_affected":[],"package":"quasar","purl":null,"source":"GHSA-3r53-75j5-3g7j"},{"ecosystem":"npm","fixed":["2.22.0"],"introduced":["0"],"last_affected":[],"package":"quasar","purl":"pkg:npm/quasar","source":"GHSA-3r53-75j5-3g7j"}],"prev":{"headline":"PostCSS: Path Traversal in Previous Source Map Auto-Loading (sourceMappingURL) leads to Arbitrary .map File Disclosure","id":"CVE-2026-73646"},"products":["quasar"],"published":"2026-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-13","vendors":["quasarframework"]},"summary":"Attackers can pollute Object.prototype via the extend utility, leading to code execution or denial of service in applications using Quasar Framework.","url":"https://insights.sbomify.com/CVE-2026-73647/"}