# CVE-2026-73647: Quasar Framework: Prototype pollution in Quasar extend() utility

> Attackers can pollute Object.prototype via the extend utility, leading to code execution or denial of service in applications using Quasar Framework.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-3r53-75j5-3g7j

## What is CVE-2026-73647?

CVE-2026-73647 is a medium-severity code injection vulnerability in quasarframework quasar, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Quasar Framework is a framework for building high-performance Vue.js user interfaces. Prior to 2.22.0, the public extend() utility in ui/src/utils/extend/extend.js recursively copied attacker-controlled object keys during extend(true, target, source) deep merges without rejecting an own __proto__ property. The merge could descend into the prototype object and write attacker-controlled properties to Object.prototype in the same JavaScript process. Applications that passed user-controlled or partially user-controlled objects to extend() could experience logic bypass, unsafe default-option injection, denial of service, or other application-specific impact when polluted properties were later consumed. This issue is fixed in version 2.22.0.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-73647?

2 open source packages ship an affected version, including quasar.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `quasar` | npm | All versions | 2.22.0 |
| `quasar` | npm | All versions | 2.22.0 |

## How do I fix CVE-2026-73647?

Upgrade quasar to 2.22.0 or later.

## Is CVE-2026-73647 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73647 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73647 and fix it if it is affected.

What it is: CVE-2026-73647 is a medium-severity code injection vulnerability in quasarframework quasar, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73647 exists.

Affected packages and fixed versions:
- quasar (npm): affected all versions; fixed in 2.22.0
- quasar (npm): affected all versions; fixed in 2.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73647/ (Markdown: https://insights.sbomify.com/CVE-2026-73647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73647
- OSV: https://osv.dev/vulnerability/CVE-2026-73647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73647/
Summaries are generated and may contain mistakes; the official description above is the record.
