# CVE-2026-73654: Trigger.dev: Prototype pollution via run metadata operations → process-wide cross-tenant DoS

> Attackers can pollute Object.prototype via metadata operations, causing process-wide denial of service affecting all tenants.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-p28v-f755-9qrg, MINI-763p-gp56-9ph8

## What is CVE-2026-73654?

CVE-2026-73654 is a high-severity code injection vulnerability in triggerdotdev trigger.dev, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Trigger.dev is a platform for building and deploying fully managed AI agents and workflows. From 3.3.8 until 4.5.6, the PUT /api/v1/runs/:runId/metadata endpoint passes attacker-controlled operation.key values to new JSONHeroPath(operation.key).set(newMetadata, value) in packages/core/src/v3/runMetadata/operations.ts without rejecting dangerous constructor and prototype path segments. A caller with a normal environment API key can pollute Object.prototype in the shared webapp process, corrupting Prisma queries and Prometheus labels, breaking other tenants' worker authentication, and causing a process-wide denial of service. This issue is fixed in version 4.5.6.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-73654?

2 open source packages ship an affected version, including @trigger.dev/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@trigger.dev/core` | npm | From 3.3.8 | 4.5.6 |
| `@trigger.dev/core` | npm | From 3.3.8 | 4.5.6 |

## How do I fix CVE-2026-73654?

Upgrade @trigger.dev/core to 4.5.6 or later.

## Is CVE-2026-73654 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73654 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73654 and fix it if it is affected.

What it is: CVE-2026-73654 is a high-severity code injection vulnerability in triggerdotdev trigger.dev, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-73654 exists.

Affected packages and fixed versions:
- @trigger.dev/core (npm): affected from 3.3.8; fixed in 4.5.6
- @trigger.dev/core (npm): affected from 3.3.8; fixed in 4.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73654/ (Markdown: https://insights.sbomify.com/CVE-2026-73654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73654
- OSV: https://osv.dev/vulnerability/CVE-2026-73654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73654/
Summaries are generated and may contain mistakes; the official description above is the record.
