CVE-2026-73667 OpenChoreo: Authenticated OS command injection via OpenChoreo Workflow Plane templates enables code execution in privileged pods
Authenticated attackers can execute arbitrary OS commands in privileged workflow pods via template interpolation, leading to code execution and potential privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73667?
CVE-2026-73667 is a high-severity command injection vulnerability in openchoreo, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
OpenChoreo is a complete, open-source developer platform for Kubernetes. Prior to 1.0.4, 1.1.4, and 1.2.0-rc.2, OpenChoreo Workflow Plane templates under samples/getting-started/workflow-templates/ interpolated developer-controlled workflow parameters into shell program text executed through sh -c instead of passing the values through container.env, allowing arbitrary commands to run in workflow pods while affected privileged Podman templates lacked hostUsers: false. This issue is fixed in versions 1.0.4, 1.1.4, and 1.2.0-rc.2.
Weakness: CWE-78
Which versions are affected by CVE-2026-73667?
7 open source packages ship an affected version, including github.com/openchoreo/openchoreo.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openchoreo/openchoreo Go | All versions | 1.0.4, 1.1.4, 1.2.0-rc.2 |
github.com/openchoreo/openchoreo Go | All versions | 1.0.4 |
github.com/openchoreo/openchoreo Go | All versions | 1.0.4 |
github.com/openchoreo/openchoreo Go | From 1.1.0 | 1.1.4 |
github.com/openchoreo/openchoreo Go | From 1.1.0 | 1.1.4 |
github.com/openchoreo/openchoreo Go | From 1.2.0-rc.1 | 1.2.0-rc.2 |
1 more packages
github.com/openchoreo/openchoreo Go | From 1.2.0-rc.1 | 1.2.0-rc.2 |
How do I fix CVE-2026-73667?
Upgrade github.com/openchoreo/openchoreo to a fixed version for your release line: 1.0.4, 1.1.4 or 1.2.0-rc.2.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-73667 being exploited?
There is no known exploitation of CVE-2026-73667 in the wild and no public exploit code.
Sources
Also known as GHSA-2mw5-23gm-pccq, GO-2026-6357.