# CVE-2026-73667: OpenChoreo: Authenticated OS command injection via OpenChoreo Workflow Plane templates enables code execution in privileged pods

> Authenticated attackers can execute arbitrary OS commands in privileged workflow pods via template interpolation, leading to code execution and potential privilege escalation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-2mw5-23gm-pccq, GO-2026-6357

## What is CVE-2026-73667?

CVE-2026-73667 is a high-severity command injection vulnerability in openchoreo, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenChoreo is a complete, open-source developer platform for Kubernetes. Prior to 1.0.4, 1.1.4, and 1.2.0-rc.2, OpenChoreo Workflow Plane templates under samples/getting-started/workflow-templates/ interpolated developer-controlled workflow parameters into shell program text executed through sh -c instead of passing the values through container.env, allowing arbitrary commands to run in workflow pods while affected privileged Podman templates lacked hostUsers: false. This issue is fixed in versions 1.0.4, 1.1.4, and 1.2.0-rc.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-73667?

7 open source packages ship an affected version, including github.com/openchoreo/openchoreo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openchoreo/openchoreo` | Go | All versions | 1.0.4, 1.1.4, 1.2.0-rc.2 |
| `github.com/openchoreo/openchoreo` | Go | All versions | 1.0.4 |
| `github.com/openchoreo/openchoreo` | Go | All versions | 1.0.4 |
| `github.com/openchoreo/openchoreo` | Go | From 1.1.0 | 1.1.4 |
| `github.com/openchoreo/openchoreo` | Go | From 1.1.0 | 1.1.4 |
| `github.com/openchoreo/openchoreo` | Go | From 1.2.0-rc.1 | 1.2.0-rc.2 |
| `github.com/openchoreo/openchoreo` | Go | From 1.2.0-rc.1 | 1.2.0-rc.2 |

## How do I fix CVE-2026-73667?

Upgrade github.com/openchoreo/openchoreo to a fixed version for your release line: 1.0.4, 1.1.4 or 1.2.0-rc.2.

## Is CVE-2026-73667 being exploited?

There is no known exploitation of CVE-2026-73667 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-73667 and fix it if it is affected.

What it is: CVE-2026-73667 is a high-severity command injection vulnerability in openchoreo, published on 13 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-73667 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openchoreo/openchoreo (Go): affected all versions; fixed in 1.0.4, 1.1.4, 1.2.0-rc.2
- github.com/openchoreo/openchoreo (Go): affected all versions; fixed in 1.0.4
- github.com/openchoreo/openchoreo (Go): affected all versions; fixed in 1.0.4
- github.com/openchoreo/openchoreo (Go): affected from 1.1.0; fixed in 1.1.4
- github.com/openchoreo/openchoreo (Go): affected from 1.1.0; fixed in 1.1.4
- github.com/openchoreo/openchoreo (Go): affected from 1.2.0-rc.1; fixed in 1.2.0-rc.2
- github.com/openchoreo/openchoreo (Go): affected from 1.2.0-rc.1; fixed in 1.2.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-73667/ (Markdown: https://insights.sbomify.com/CVE-2026-73667/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-73667
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-73667
- OSV: https://osv.dev/vulnerability/CVE-2026-73667

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-73667/
Summaries are generated and may contain mistakes; the official description above is the record.
