CVE-2026-73840 OpenChoreo: Unauthenticated build/workflow trigger via git-provider confusion (webhook signature bypass)
Attackers can trigger unauthenticated builds and workflows by bypassing webhook signature verification, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-73840?
CVE-2026-73840 is a medium-severity authentication bypass vulnerability in openchoreo, published on 13 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OpenChoreo is a complete, open-source developer platform for Kubernetes. Prior to 1.0.3, 1.1.3, and 1.2.0-rc.2, the POST /api/v1alpha1/autobuild endpoint in internal/openchoreo-api/api/handlers/webhook_handler.go selected a webhook provider from caller-controlled X-Event-Key, accepted Bitbucket requests without HMAC-SHA256 in X-Hub-Signature or a configured bitbucket-secret, and allowed unauthenticated build triggers for components matched by repository URL and branch, including cross-provider triggers using attacker-supplied commit SHAs. This issue is fixed in versions 1.0.3, 1.1.3, and 1.2.0-rc.2.
Which versions are affected by CVE-2026-73840?
7 open source packages ship an affected version, including github.com/openchoreo/openchoreo.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openchoreo/openchoreo Go | All versions | 1.0.3, 1.1.3, 1.2.0-rc.2 |
github.com/openchoreo/openchoreo Go | All versions | 1.0.3 |
github.com/openchoreo/openchoreo Go | All versions | 1.0.3 |
github.com/openchoreo/openchoreo Go | From 1.1.0 | 1.1.3 |
github.com/openchoreo/openchoreo Go | From 1.1.0 | 1.1.3 |
github.com/openchoreo/openchoreo Go | From 1.2.0-rc.1 | 1.2.0-rc.2 |
1 more packages
github.com/openchoreo/openchoreo Go | From 1.2.0-rc.1 | 1.2.0-rc.2 |
How do I fix CVE-2026-73840?
Upgrade github.com/openchoreo/openchoreo to a fixed version for your release line: 1.0.3, 1.1.3 or 1.2.0-rc.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-73840 being exploited?
There is no known exploitation of CVE-2026-73840 in the wild and no public exploit code.
Sources
Also known as GHSA-c5f6-2rm9-2w8g, GO-2026-6360.